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What Is Mapmaker’s Toolkit?

Mapmakers Toolkit is an easy-to-use software program that allows students
and teachers to customize and print current and historical maps. The pro-
gram has three powerful features:

Find Maps
Mapmakers Toolkit contains an extensive library of over 450 current and
historical maps, including:

* 7 continents and 4 oceans

* 20 world regions

* 191 countries and 33 dependencies

* 50 U.S. states and Washington, D.C., and 5 U.S. regions

* 13 Canadian provinces and territories

* 125 historical maps (U.S. history, ancient civilizations, Middle Ages,

colonial era, twentieth century, and more)

* 48 theme maps (precipitation, land use, temperature, population
density, vegetation)

Customize Maps

Create simple outline maps or highly detailed physical or political maps with
the program’s built-in Layers feature. Also, you can easily add your own color
and text to any map. The special Border Fill feature lets you fill any political
area with color. In addition, there are over 800 stamps in 30 categories,
including animals, crops, transportation, and flags of the world. With these
powerful tools, you and your students can customize any map to illustrate a
lesson, report, or presentation.

Publish Maps

Mapmakers Toolkit makes it easy to publish your map in print (on one or
multiple pages), or electronically with Mapmakers Slideshow, or on the
Internet.
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What You Get & What You Need

What You Get

* Hybrid Macintosh/Windows CD-ROM
* This Teacher’s Guide

What You Need

At least a 20 megs
Macintosh LC III
4 (24 megs
(68040 processor) 7.1 or later recommended) 256-color:
640 x 480 monitor 20 megabytes of | Double-speed
Macintosh Power PC resolution or higher free disk space or higher
24 megs
IBM-compatible Windows 95 (32 megs
486 or higher or higher recommended)

Map Reproduction Rights

Mapmakers Toolkit gives you the power to customize and publish a variety
of maps. You are free to produce maps for personal, classroom, and non-
commercial uses only. Mapmaker’s Toolkit maps are copyrighted materials,
and therefore may not be reproduced in books, commercial software, on
commercial Internet sites, or broadcast on television.

When you export a map for use in publications, or on school-related or
personal (non-commercial) Internet sites, please do not obscure any copyright
information on the map. We also ask that you include the following credit:
“From Mapmaker’s Toolkit" by Tom Snyder Productions.”

Thank you!
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WalkThrough

This section steps you through the process of finding, customizing, and
publishing a map. You'll learn how to

* locate the map you want

* turn map layers on and off

* add your own features to the map

* print a map

* save a map for Mapmaker’s Slideshow

* create a slideshow
As you become familiar with the program, you’ll begin to see all sorts of ways
that you and your students can use Mapmaker’s Toolkit. More information

about each subject covered in the WalkThrough is available in the Features &
Functions section of this guide, and also in the program’s online Help feature.

Install the Software

Macintosh

1. Insert the CD-ROM into the CD-ROM drive.
Double-click the CD-ROM icon to open the CD.
Double-click the Mapmaker’s Toolkit Installer.

Follow the on-screen instructions to install the program.

AR S

To launch the application, double-click the Mapmaker’s Toolkit icon

on your computer’s hard drive.

After you launch the application, click Continue on the Mapmakers Toolkit
title screen. A map of the world appears, and you're ready to begin your journey.

Windows 95 or Higher
1. Insert the CD-ROM into the CD-ROM drive.
From the Start menu, choose Run.

Type D:/SETUP, where D is your CD-ROM drive.

Follow the on-screen instructions to install Mapmakers Toolkit.

AR

To launch the application, go to the Start menu and choose Mapmaker's
Toolkit from the Programs folder.

After you launch the application, click Continue on the Mapmakers Toolkit
title screen. A map of the world appears, and you're ready to begin your journey.

Mapmaker's Toolkit Installer icon

Mapmaker’s Toolkit program icon
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Find a Map

The first thing to do is decide where you want to go. Mapmakers Toolkit
gives you ready access to over 450 present-day and historical maps. Lets
take a quick trip around the world so you can become familiar with the
kinds of maps available in Mapmaker’s Toolkiz, and ways to find them.

Current Maps

Hold the cursor over any of the place names on the world map. The arrow
turns into a pointing hand. This indicates that the name is a “hot link” —
clicking it links to a map of that area. On the world map, you can navigate
to any of the seven continents or four oceans.

g LAYERS }
o @ : ] LEGEND }
|The World|
drctic Qeean
EUVEOPE
NORTH ASIA
Pacific AMERICAS 4,y ntic Pacific
Qcean Qcean Qcean
AFRICA
SOUTH
AUSTRALIA
AMERICA : AUSTRALIA
Back & OCEANIA .:)nd! an & OCEANIA
Atlantic cean
anrd OCQGH a 2,000 Hil
Pacific o
OCG£H i} 2,000 Kilometers
ANTARCTICA
EEensystems

Ready

World map in Find mode

Click Africa. A map of the continent of Africa appears.

Every African country is labelled, and is hot-linked. Locate Madagascar, in
the Indian Ocean off the east coast of Africa, and click its name. The map

of Madagascar appears. From this map, you can travel to Mozambique,
Mauritius, or Comoros. Notice that the text label for Reunion, a dependency
of France, is different from the other place names. Reunion does not have a
hot link, and a more detailed map is not available.




The three small maps at the top of the screen are navigation maps.

Navigation maps for Madagascar

They show you where you are in the world. In Madagascar, you'll see a map
of the world, a map of Africa, and a map of Southern Africa. You can use the
navigation maps to access the regions and continents they represent. Click
the navigation map of Southern Africa. A map of Southern Africa appears,
showing all the countries in that region.

Now, click Back on the toolbar. The map of Madagascar appears again.
Clicking Back again will bring you to the continent map of Africa. If you
click Forward, you go to the map you viewed most recently, Southern Africa.
The Back and Forward buttons make it easy to trace the path of maps you
have viewed, or flip between two or three maps.

Let’s go to Asia. How are we going to get there? You could return to the world
map, and navigate from there to Asia, but there’s a quicker way. Click Cur-
rent Maps on the toolbar, or choose Current Maps from the Find menu. The

Find Current Map dialog box appears.

Find Current Map

Name TLul:atiun ]

Arctic Ocean
Argentina

Arizona

Arkansas

Armenia

Aruba

[Asia |

Asia {(Close-up)
Atlantic Ocean (North)
Atlantir firean fAnuthy

]

4]

Find Current Map dialog box

WalkThrough
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Back button

1

Forward button

£1O

Current Maps button

MAPMAKRER'S
TOOLKIT




WalkThrough

MAPMAKER'S
TOOLKIT

LAY ERS

Layers button

To find the map of Asia:

1. Scroll down the list until you see Asia.

2. Click Asia, then click Display.

3. The continent map of Asia appears on the screen.

Alternatively, you can type “Asia” into the text box, and the list will jump to
the appropriate alphabetical location.

Now, let’s travel to Europe using the map list again. Click Current Maps on
the toolbar, or choose Current Maps from the Find menu. The Find Current
Map dialog box appears. This time, we'll find the map we want by location:

1. Click the Location tab in the Find Current Map dialog box.

2. You'll see an indented list of continents and oceans underneath the
“World” label. Places with a marker (a triangle on Macintosh, a plus sign
on Windows) to their left contain more maps underneath.

3. Click the Europe label to select it and click Display. If you want to see a

list of the places in Europe, click the marker next to Europe.

Mapmaker’s Toolkit divides the continents of Africa, Asia, and Europe into

regions. To see these regions, you'll use the program’s Layers feature. We'll

talk more about working with layers later on. Right now, we'll just turn on
the region layers and names so we can use them to navigate.

To turn on the regions of Europe:

1. Choose See Layers from the Options menu, or click the Layers button in
the upper right corner of the screen.

2. A dialog box appears listing all the layers available for the map of Europe.

Europe map & Europe Layers dialog box
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3. Click the Region Boundaries and Region Names labels. Check marks
now appear next to these layers, indicating that they will be turned on
when you click Apply or OK. (Apply lets you preview your changes
without closing the Layers dialog box.)

4. Click Apply. The regions of Europe appear on the map.
5. Click OK.

When you pass the cursor over these region labels (shown in purple), it turns
into a pointing hand, indicating that they are hot-linked. You can navigate to
these areas in the same manner as continents and countries.

Note: To navigate to a continent, region, or country, both its boundaries and its
name must be turned on in the Layers dialog box.

Historical Maps

So far, we have found only present-day maps. Mapmakers Toolkit also in-
cludes a library of over 125 historical maps of areas all around the world.
These maps are correlated to major historical events and topics. Let’s look
at a historical map of Greece.

1. Click Historical Maps on the toolbar, or choose Historical Maps from 3
the Find menu. Historical

2. The Find Historical Map dialog box appears. You can locate historical "ﬂn
maps by date, by location, or by topic. Use one of the methods described Historical Maps button

below to access the map of Greece in 480 B.C.

By date: Click the marker next to the date range of 999 — 1 B.C. This opens
a list of maps within that range. Select the map titled “480 B.C. Greece,” and
click Display.

By location: Click the Location tab. Scroll through the alphabetical list of
locations until you see the maps of Greece. Select “Greece” next to 480 B.C.

and click Display.

By topic: Click the Topic tab. Open the Ancient Civilizations topic heading
by clicking the marker to its left. Now open the Greece topic heading. Click
“Greece (Regions and City-States) 480 B.C.” and click Display.

The map of ancient Greece appears. You can access any historical map using
one of the three methods described above.

Note: Historical maps do not have hot-links. You cannot navigate through
historical maps by clicking on them, the way you can with present-day maps.

MAPMAKRER'S
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Add Bookmark button

You can also return
to the world map

by choosing New
from the File menu.
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Bookmarks

The final stop on our world tour is the present-day United States.

1.

Click Current Maps on the toolbar or choose Current Maps from the
Find menu. The Find Current Map dialog box appears.

Type “United S” into the text box. The list jumps to the U.S. states, and
highlights it.

Click Display. The map of the 50 U.S. states appears. (The program also
includes a map of the 48 continental United States.)

Since you'll probably use this map frequently, let’s bookmark it so you can
find it again quickly. Click Add Bookmark on the toolbar, or choose Add
from the Bookmarks menu. The map is now added to your list of bookmarks

that you can use to access the map at any time. Try it out:

1.

Return to the world map by clicking the World navigation map at the top
of the screen.

Choose Organize/Select from the Bookmarks menu. The Bookmarks
dialog box appears.

Click the United States bookmark, and click Go to Map. The dialog box
goes away, and the United States map appears.

Bookmarks

4 Bookmark List New Folder |
P dUnited States

Go to Mapg

Bookmarks dialog box

You can easily organize your bookmarks into folders. This is especially helpful

if there are multiple users adding bookmarks within the program. They can
create folders of bookmarks labelled with their names. To find out more

about adding, deleting, and organizing bookmarks, see page 39.




WalkThrough

Customize Your Map

Now that you've found a map, you'll learn the many ways you can customize
it to suit your needs. Mapmaker’s Toolkit can help you quickly and easily
 map the places students visited during summer vacation
* create a map of the major products of South America
* remove the names of major U.S. rivers from a map and have students
fill in that information
* show the industries of your state or region
* depict the significant battles of World War II

¢ and much, much more

To illustrate some of the capabilities of the program, we'll create a map of
population data for the United States.

Layers

The first step in customizing your map is turning on and off the built-in
layers. Built-in layers include rivers, shaded relief, cities, and so on. Turn
to page 43 to see a chart that lists all available layers for each type of map.

Open the map of the United States, if it is not already open. To access the LAYERS

map layers, click the Layers button in the upper right corner of the screen, Layers button
or choose See Layers from the Options menu. The Layers dialog box appears.
This is what you'll see for the United States map:

United States Layers
Paoliical Featres

K
Subject Highlight
State Boundares
State Marmes
[] Region Boundaries
] Region Marnes Mone
Intemmational Boundares
Country Marm es Carcel
[] Cities '
Physical Featires

Relief
[] Rivers
] Rirver Marnes
[] Grid
Title
Water BodyHames

Spply |

United States Layers dialog box
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You can easily choose

to display all the layers,
by clicking All, or none of

the layers by clicking None.

BN CcEanwY FinD ‘1

Find and Draw tabs

MAPMAKER'S
TOOLKIT

Notice that certain layers have check marks next to them. Those are the layers
that are turned on by default. Experiment with turning layers on and off.
First, click Cities. A check mark appears in the Cities box. Before you can see
the change take place on the map, you must click Apply. This updates the
map with any changes you have made to the layers. Click Apply to see the
major cities of the United States appear on the map.

Now click Relief to turn it off, and click Apply. The shaded relief disappears
from the map. The United States (the subject of the map) is highlighted in
tan while other areas appear in yellow. You can turn off the tan subject

highlight by clicking Subject Highlight at the top of the list.

Try other combinations of layers to see the various ways the map can look.

Remember that you won’t be able to see a change until you click Apply or OK.
When you are finished, click OK.

Draw Mode

You may have noticed the tab on the left side of the screen that says Draw.
Find and Draw are the two distinct modes in which you can use Mapmaker’
Toolkit. Find mode allows you to access maps. Draw mode allows you to
customize a map by adding your own stamps, text, and color. You can turn
built-in layers on and off in both Find and Draw modes.

So far, we have worked only in Find mode to access a variety of maps and
turn layers on and off. Now let’s switch to Draw mode to continue creating
our map of United States population data.

1. Ifitis not already open, find the map of the United States. Do not worry
about which built-in layers are showing, because you'll have the ability to
change them in Draw mode.

2. Click the Draw tab on the left side of the screen. The program now
switches to Draw mode. The Draw toolbar replaces the Find toolbar.




The following tools are available on the Draw toolbar:

Marquee tool
Select and move lines
and shapes you have
drawn on the map. Pencil tool
Draw freehand lines.
Line tool
Draw straight lines.
Ellipse tool
Draw ellipses.
Rectangle tool
Draw rectangles.
Eraser tool
. Erase lines and shapes
Standz?qu Fill tool you have drawn.
Fill in shapes w

you have drawn. Border Fill tool
Fill in any political area on
Selection tool the map.
Select text and
stamps you have

added to the map.

Text tool
Add text
to the map.
Stamp tool
Add stamps
to the map.

Undo tool
Undo the last action
you performed.

Notice that in Draw mode, there are four new layers listed under “My Fea-
tures” in the Layers dialog box that were not listed in Find mode. Draw, Text,
Stamps, and Border Fill represent items you add to the map in Draw mode.

My Featres

Diraw
Stanps ——————
Test ———
Biord er Fil

5*1
=3

My Features and Draw toolbar

WalkThrough
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Before we start our map of U.S. population data, we will adjust the layers
that appear on the map. Click Layers or choose See Layers from the Options
menu. First, click All to turn on all the layers. Then, turn off the layers listed
below and click OK.

Turn off these layers: The dialog box will look like this:

Reglon Boundarles =——— United States Layers

Relief Poliical Featres

Rivers Subject Highlight

Grid State Boundaries

. State Marnes

Title [] Region Boundaries

Water Body Names L] Region hiames None |
Interational Boundaries

Country Mames
Cities
Physical Fealures

[ Reiet
[ Rivers
[ Rivver Marnes
[ rid
] Title
[ ater BodyMamnes

My Features

Drratw
Starmps
Text
Border Fil

o]

Apply |

Cancel |

Customized United States Layers dialog box

Note: At any time during this Walk Through, you can save your map and
continue working later.

1. Choose Save or Save As from the File menu. A dialog box appears.
2. Navigate to the place where you want to save your map.

3. In the text box, type a name for your map.

4. Click Save.
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Stamps

Let’s begin to customize the map by identifying the most populous metropoli-
tan areas in the United States. We'll use square markers to identify these cities.

1. Click the Stamp tool on the toolbar. At the top of the screen, a row of & I

stamps appears.

Stamp tool
2. From the pop-up menu, choose the stamp set called “Markers - Squares.”
A row of small, colored square markers appears.
Stamp Set Stamps
| \ \
[ Markers=Squares - | =
= A [= [=] = = [= a [=]
Equare (med. red) | = =
Stamp Name Scroll Arrows See All in Set
3. Click the down scroll arrow to the left of the stamps once to scroll down IR s
to the second row of markers, which are slightly larger than the first row. t | p

4. Drag a red square marker from the top of the screen and place it on
top of the dot for New York City. Drag another red marker and place it

You can position a stamp
more precisely by selecting it

on top of Los Angeles. Continue this process for the remaining three and using the arrow keys on
cities listed below. Don’t worry if you slightly cover the name of a city, the keyboard to move it
because we will turn off the city names later. one pixel at a time.

The most populous metropolitan areas in the U.S. are:

. New York

. Los Angeles
Chicago

. Washington, D.C.

5. San Francisco

h-lkyél\)n—t

Data: U.S. Census Bureau

If you want to move a marker after you have placed it:

1. Click the Stamp tool or the Selection tool on the toolbar. ‘ I

2. On the map, click the stamp you want to move to select it. A stamp is Selection tool
selected when it has a red box around it.
3. Drag the stamp to a new location and release the mouse button.

Note: The Selection tool allows you to select and move both text and stamps youve
placed on your map.

MAPMAKRER'S
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Undo button

&

Stamp tool

If you make a mistake, you can fix it by immediately clicking Undo on the
toolbar or choosing Undo from the Edit menu. (This works only on the last
action you performed.)

You can also delete stamps from your map with the Stamp or Selection tool:
1. Select the item you wish to delete using the Stamp or Selection tool.

2. Choose Delete from the Edit menu.

When you're finished placing the square markers on your map, open the
Layers dialog box again and turn off the Cities layer. This is how your map

should look:
i
. mCANiDA \L\J‘% ) W\k
l.- . ) n 200 Milzs \ ;

@EeoSyskems

0 200 Kilorneters

o I img
L \?n-
=gUBA !

==

United States Population Map: Stage 1

Now, let’s identify the U.S. states with the largest populations. We'll use
human figures to symbolize a large population.

1. Click the Stamp tool on the toolbar.

2. From the pop-up menu, choose the stamp set called People. A row of
people of different shapes and sizes appears.

3. From the row of stamps, drag the second figure from the left (called “boy,
med.”) and place it in California. Place another figure in Texas. Continue
this process for all ten states listed on the next page. Don't worry if you
cover the name of a state, because we will turn off the state labels later.




The ten most populous states are:

1. California (CA) 6. Illinois (IL)

2. Texas (TX) 7. Ohio (OH)

3. New York (NY) 8. Michigan (MI)
4. Florida (FL) 9. New Jersey (N])*
5. Pennsylvania (PA) 10. Georgia (GA)

Data: U.S. Census Bureau

* New Jersey is not big enough to hold a figure. Place the stamp to the right
of New Jersey. Later, we'll use the Line tool to draw a line from the symbol
to the state.

When you're finished, this is how your map should look:

EEe0Systems CANADA \L\J‘% [:?
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United States Population Map: Stage 2

Border Fill

The Border Fill feature of Mapmakers Toolkit lets you fill in with color any
area enclosed by boundaries, including states, regions, countries, and land
areas. When you fill a country or other political area, the Border Fill tool will

also fill non-contiguous areas (for example, it will fill Long Island when you
fill New York).

WalkThrough
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You can also use the
Border Fill tool to fill in
water and the shoreline
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ol

Border Fill

tip

on your map.

Border Fill Eraser

As a general rule, when there is more than one boundary layer showing, the
Border Fill tool will fill the smallest visible political area. For example, on

the United States map, if you use the Border Fill tool when international,
regional, and state boundaries are all turned on, it will fill individual states.
To fill regions, you must open the Layers dialog box and turn off the State
Boundaries layer. Once the state boundaries are no longer showing, the
regions become the smallest political areas on the map, and they will be filled
when you use the Border Fill tool. After you've filled the regions, you can
turn the state boundaries back on. This will not change any border fill you
have already added to your map.

For our population data map, we'll fill in the most densely populated states.

1. Click the Border Fill tool on the toolbar. The cursor changes to a paint
bucket with a “B” in it.

2. Choose a color for the border fill by clicking a color in the color palette
at the top of the screen. The color you select is displayed in the rectangu-
lar area to the right of the palette. For this map, choose light brown (in
the middle of the bottom row).

3. Click inside Connecticut. It fills with light brown. Click inside each state
listed below to fill them all with light brown.

Following are states with a population density of greater than 250 people per
square mile:

Connecticut (CT) New Jersey (N]J)
Delaware (DE) New York (NY)
Florida (FL) Ohio (OH)
Maryland (MD) Pennsylvania (PA)
Massachusetts (MA) Rhode Island (RI)

Data: U.S. Census Bureau

If you make a mistake and fill the wrong state, you can correct it using the
Border Fill Eraser.

To remove border fill:

1. Click the Border Fill tool on the toolbar.

2. Click the Border Fill Eraser at the top of the screen. The cursor becomes
an “X'”

3. Click inside the area from which you want to remove the color. The
border fill in that area disappears.

Note: The Border Fill Eraser will erase only border fill. It will not erase lines,
shapes, text, or stamps you have added to the map.




Finally, return to the Layers dialog box and turn State names off. Click OK.
Your map should now look like this:
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United States Population Map: Stage 3
Note: Remember, you can save your map at any time and continue working later.

Lines and Shapes

You can add lines and shapes of various colors and sizes to your map. On this
map, we'll add a leader line for the population symbol we placed outside New
Jersey. We'll also draw a circle around the most densely populated region of
the country, the Northeast.

First, we'll use the line tool to draw a line between New Jersey and the high
population symbol we placed to the right of the state.

1. Click the Line tool on the toolbar.

color palette line width line style
| | ] ]

(el O Om T

Line tool options

2. Choose a width and style for your line by clicking one of the options at
the top of the screen. You can choose a line width of 1, 2, 4, 6, or 8
pixels, and a solid, dotted, or dashed style. For this map, choose 2 pixels
(second from the left).

WalkThrough

AN
||

Smaller areas

(like Rhode Island) may

be hard to fill at this size.
You can zoom in on your map
by clicking the Zoom In button
at the bottom left of the screen,
or choosing Zoom In from the
View menu. This enlarges the
map to make it easier to see.
When you're finished, you can

Zoom Out to return the

map to normal size.

salub)

Zoom Out & Zoom In buttons

N\

Line tool

To draw a straight line,
hold down the Shift key
while drawing a line.
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Undo button

2 |

Eraser tool

L1

Marquee tool

o

Ellipse tool

3. You can choose a color for your line by clicking a color on the color
palette at the top of the screen. The color you have selected is displayed
in the rectangular area to the right of the palette. Choose black for this line.

4. Click and drag with the mouse to create a line between the symbol and
New Jersey.

If you make a mistake, there are several ways you can delete a line:

Undo

Click Undo on the toolbar or choose Undo from the Edit menu to undo
something you just did. This works only on the last action you performed.

Eraser

With the Eraser tool, you can delete lines or shapes you have drawn pixel
by pixel. Note that the eraser does not work on stamps or border fill you've
added to the map. To use the eraser:

1. Click the Eraser tool on the toolbar.

2. Choose a size for your eraser by clicking one of the options at the top
of the screen. The eraser can be 1, 6, 12, or 18 pixels.

3. Click and drag the eraser through the area you want to erase.

4. If you accidentally erase something, click Undo on the toolbar or choose
Undo from the Edit menu.

Marquee

You can also use the Marquee tool to select and delete a line or shape you
have drawn. Click the Marquee tool on the toolbar. Select the item you wish
to delete by dragging the crosshairs over it. The tool forms a dashed shape
around the selected item. Then choose Delete from the Edit menu. This
deletes all lines you have drawn that are within the selected area, but does
not delete stamps or border fill.

Now, let’s draw a circle around the Northeast, the most densely populated
region of the United States.

1. Click the Ellipse tool on the toolbar.

2. Choose a width for the border of your circle by clicking one of the
options at the top of the screen. You can choose a width of 1, 2, 4, 6,
or 8 pixels. Choose 2 pixels.

3. Choose a color for your circle by clicking a color on the color palette at
the top of the screen. The color you have selected is displayed in the
rectangular area to the right of the palette. For this map, choose red.

4. Click and drag with the mouse to create an ellipse around the Northeast.




Text

The only thing the map needs now is a title.

1.

Click the Text tool on the toolbar, then click anywhere on the map.
The Text Tool dialog box appears.

Type the title “United States Population Data” into the text box.

Make the title larger by choosing 18 point from the Size pop-up menu.
You can find out about other text formatting options on page 51.

Click OK. Your text appears on the map.

Text Tool

Font

Size

Text

[ Helvetica

] (5,7

United States Population Dat{{

Alignment style Rotation *

FE= mzy
| sample |
- S ‘w

() Box

(2 Background [JTransparent

Text Tool dialog box

To move the title to another location:

1. Select the title using the Selection tool or the Text tool.

2. Drag it to a new location and release the mouse button.

3. Remember, you can position the text more precisely by selecting it and

using the arrow keys on the keyboard to move it one pixel at a time.

Your completed map looks something like this:
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United States Population Map: Completed
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Legend button

Building the Legend

So, now you've completed your map. You've added stamps, color, and a title.
But you need to make sure other people who look at the map understand
what all these items signify. Your map needs a legend.

A powerful feature of Mapmaker’s Toolkit is the ability to automatically build
a legend that includes all items you've added to your map. You can then edit
the legend text to tailor it to your subject.

To build your legend:

1. Choose Show Legend from the Options menu, or click the Legend
button in the upper right corner of the screen. The Legend dialog box
appears. The legend shows nine standard items included on the United

States map.
Legend
International, State, ar Regional Eoundar _ Disputed or
Provinzial Boundary d Y “Water Boundatry
Y
River Map Subject Area Park
. X State or Provinzial X
#  MNational Capital ® Capital L City
W
Euild Legand |

Standard Legend

2. Click Build Legend. Buttons appear at the bottom of the dialog box.
3. We do not need to display any of the standard legend items for our map.
Click Hide Basic Legend. The nine items disappear.

4. Click Update. The legend will update to include any color or symbol
youve added to the map. For the map we've created, it will look like this:

Legend
. Mew Entry Mew Entry . Mew Entry
rs
E  =quare {med. red) |n| boy Crmed.)
-
[ update | |_Hide BasicLegend | [ Delete | |__add symbal |
[ShowEBasiclegend | [ EditText |

United States Population Data Map Legend: Updated
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We'll edit the legend by first deleting any items we don’t need, such as the
black square. This represents the black line we drew between New Jersey and
the high population symbol. To delete the black square, click it to select it, and
then click Delete. A dialog box will appear confirming your choice. Click Yes.

Now, we'll edit the text of the remaining items on the map.

1. Click the light brown square to select it.
2. Click Edit Text. The Legend Entry Text dialog box appears.

3. In the dialog box, type the new text:
On line 1: Population density more
On line 2: than 250 people/sq. mile

(You are limited to two lines, and 25 characters per line.)

4. Click OK. The new text now appears in the legend.

Follow the steps above to change the text of the square marker to “Most
populous cities.” Change the text of the human figure to “Most populous
states.” Change the text of the red square to:

On line 1: Most densely populated

On line 2: region

When you've finished, the completed legend should look like this:

legend =————
Most densely populated Population density more
region than 250 people /=q. mile
Y
E Mozt populous cities @ Maost populous states
-
[ update | [ Hide Basic Legend | [ Delete | [ Add symbol |
[ShowEBasiclegend |  [__ EditText |

United States Population Data Map Legend: Completed

You do not need to do anything special to save the legend. However, if you
click Update after deleting some items, the legend will once again show all
the items you placed on the map.

MAPMAKRER'S
TOOLKIT




WalkThrough

MAPMAKER'S
TOOLKIT

Save Your Map

While working in Draw mode, you can save your map at any time to return
to later and continue working. When you save your map, any changes you
have made to the map legend will also be saved.

To save your map:

1. Choose Save from the File menu. If you have not previously saved your
map, a dialog box appears.

2. Navigate to the place where you want to save your map.

3. In the text box, type a name for your map.

4. Click Save.

Using the Save or Save As commands saves your map as a Mapmaker’s
Toolkit-type file, which can only be opened by Mapmakers Toolkit. Later,
we'll discuss how to export files in a format (PICT, BMP, or GIF) that can
be read by other programs.

To open a map you've previously created and saved:
1. Choose Open from the File menu. A dialog box appears.

2. Navigate to the place where you saved your map, select it, and click Open.
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Publish Your Map

Now that you've completed a map, you have several options for publishing it.
Mapmakers Toolkit makes it easy to print out your map, save it for publishing
on the Internet, or present it electronically using Mapmaker’s Slideshow, a

program installed on your computer’s hard drive along with Mapmaker’s Toolkit.

Print

There are many options for printing out a map. You can print on one or
multiple pages. You can print the map legend on the same page, on a separate
page, or not at all.

We'll print our map on one page, with the legend on the same page.

1. Choose Page Setup from the File menu. The Page Setup dialog box appears.

2. In the Legend area of Page Setup, click On to print the legend with
your map. It will print at the bottom of the page.

Page Setup
Legend
O off
{® On
() Separate Page
1 page 4pages (2 x2) Qpages (3 x3)
[ Frint Freview ]
[ Printer Setup... ]

16 pages (4= 4] 25 pages (5 x5) 36 pages (6 x6)

Page Setup dialog box — Macintosh

Page Setup [ %]
— Printer

Mame: fpple niter Sector 12 Properties |

Status: Default printer; Ready
Type: Applelasena/riter
where:  SwAushprint_queue
Comment:

— Paper — Orientatian
Size: IUS Letter j —  Portrait
Source: IAutDSeIect Tray j & | andscape
— — Legend
0K
& 0On
" Separate Page
1 page 4 pages [2x2) 9pages [3x3)
Frint Preview |
| Ok I Cancel |

1B pages [4%4] 25pages(5#5] 36 pages(ExE)

Page Setup dialog box — Windows
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3. Click Print Preview to see how your map will look on the page.

4. You can look at the map more closely by clicking Zoom In, or by holding
the pointer (shaped like a magnifying glass) over the map and clicking,.
You can view the map at 200 and 400 percent. (This does not cause the
map to print any larger.)

5. To zoom out again, click Zoom Out.

6. Click Print. For Macintosh users, if this is the first time you have printed
a map, the Printer Setup dialog box appears. Set the paper orientation to
landscape (horizontal). This allows the map to print at the maximum
possible size on one page. Then click OK. (To change these settings later,
you can access the Printer Setup dialog box by choosing Page Setup from
the File menu, and clicking Printer Setup.)

7. The Print dialog box appears. Click Print to send your map to the printer.

The map prints with the legend beneath it, like this:

= Ossse

O Hpmoackhs ‘ e ppleE rirsa

United States map printed with legend

Exporting a Map for Electronic Publishing

Mapmakers Toolkit makes it easy to publish your maps electronically. With
Mapmakers Slideshow, a separate program included on the Mapmaker’s Toolkit
CD-ROM, you can use your computer to create a slideshow to present your
maps. For example, you could create maps of the major crops in each region
of Africa, or document the major events leading up to the Civil War, and
present them in a slideshow.
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The Export command allows you to save your map in a format that can be
used by Mapmakers Slideshow, by word processing and painting programs,
and by HTML (Hypertext Markup Language) editors for use on the World
Wide Web.

Before you export your map, it’s a good idea to save it as a Mapmaker’s
Toolkit-type file. This allows you to return to the map later and make changes.
When you export a map as another file type, you will still be able to import
and view the map in Mapmaker’s Toolkiz, but you will no longer be able to
turn the map layers on and off, or edit text and stamps already on the map.

Export the map of U.S. Population Data for a slideshow:

1. In Mapmakers Toolkit, open the map you created of U.S. population
data, if it is not already open.

2. Choose Export As BMP (Slideshow) from the File menu. A dialog
box appears.

e I

New EN Mew Crl+r
Go to Find Gota Dirawe
Open... ®0 Open... Chk0
Save A
Save As.. Irnpoart..
Export Az BMP [Slideshow)...
Uze Blank Map Az GIF...
Import...
As BMP (Slideshow)... | Fage Setup...
| Print Chl+F
Page Setup...
Print... EP
Quit #Q Ext
File...Export Menu (Macintosh) File...Export Menu (Windows)

3. Navigate to the place where you want to save your map.
4. Type a name for your map, such as “Population Data.bmp.”

5. Click Save.
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Mapmaker’s Slideshow icon
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Adding an Image to a Slideshow

Mapmakers Slideshow, a separate program that comes with Mapmaker’s
Toolkit, allows you to put on a slideshow presentation of your maps. For
this WalkThrough, we've created a slideshow you can work with to become
familiar with some of the features of Mapmaker’s Slideshow.

Before you begin, follow the instructions in the “Exporting a Map for Elec-
tronic Publishing” section on page 27 to export your map of United States
population data for the slideshow.

When you're ready, open Mapmaker’s Slideshow.

For Macintosh: Double-click the Mapmakers Slideshow icon in the
Mapmaker Toolkit folder located on your computer’s hard drive.

For Windows: Go to the Start menu in Windows. Within the Programs
folder you'll find a Mapmakers Toolkit folder. Select Slideshow

to launch the program.

Then do the following to open the WalkThrough slideshow:

1. On the Mapmaker’s Slideshow main menu, click Open.

2. In the dialog box, navigate to the WalkThrough folder.

3. Open the WalkThrough folder, and select WalkThrough Slideshow.
Click Open.

The WalkThrough slideshow opens. A list of slides already included in

the show appears.

1o 3 e s 6 WlacHee = B | F

Dy s g
HE Ald e |
=1 [l Elide
i fuid el

B Deloic Ixaml

WalkThrough Slideshow main screen
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Let’s run the slideshow to see how it looks.
1. Click Run Slideshow, or choose Run from the File menu.

2. The slideshow begins. Click the mouse button to advance each slide. (T
You can stop the slideshow at any time by pressing the Escape (Esc) N\ L
key on your keyboard. Press the right arrow key

to advance the slideshow.

Press the left arrow key
to reverse the slideshow.

3. When the slideshow is finished, the program returns to the main screen.

Now we'll add the U.S. population data slide to the show.

1. Click Add Slide. A dialog box appears.

2. Navigate to the place where you saved the Population Data.bmp file.
3. Select the U.S. population data map, and click Open.
4

. The map name now appears at the bottom of the list of slides in
Mapmaker’s Slideshow. In addition, a small version of the map is displayed
in the preview box.

ol e s S Wl = Y | F

You can stop a slideshow
WalkThrough Slideshow with U.S. Population Data map added at any time by pressing the
Escape (Esc) key on your computer’s
Click Run Slideshow to see the slideshow again, this time with the U.S. keyboard. This returns you to the
Population Data map displayed at the end. Mapmaker’s Slideshow main screen.
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Adding a Sound to a Slideshow

Now, we'll add sound to the show. A folder of sample sounds is included on
the Mapmaker’s Toolkit CD-ROM.

To add a sound:

1. In the list of slides, click the population data slide to select it.

Click Add Sound. A dialog box appears.

Navigate to the Sample Sounds folder on the CD-ROM and open it.
Click any of the sound the files and click Open.

In the list of slides, a sound symbol now appears next to the population

You can record your own
narration and sounds.

See Add Sound to Your
Slideshow on page 67.

AR

data slide. When you run your slideshow, the sound will play.
Run the slideshow again to see the results of the changes you made.

There are many options that allow you to easily change the look and feel of
your slideshow. You can change the background color that appears around
the slides, fade slides in and out of the frame, rearrange the order of the
slides, and much more. These options are described in detail on pages 70-71.

MAPMAKER'S
TOOLKIT




Features & Functions

This section contains in-depth, step-by-step instructions for every function
of Mapmaker’s Toolkit and Mapmaker’ Slideshow. Use the Table of Contents

below as a guide for finding the information you need, or refer to the index

on page 89.
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Quick Reference Questions & Answers

How do I...

...make a black and white outline map?
In Draw mode:
1. In the Layers dialog box, turn off all boundary layers and the Subject
Highlight layer.
'{E-:. 2. Click the Border Fill tool on the toolbar and select white from the
T color palette.

Border Fill tool
The tip of the paint is
the insertion point.

Click anywhere on the land area to fill with white.
Click any body of water to fill with white.
Select black from the color palette.

Click the Zoom In button, or select Zoom In from the View menu.

NSV W

Locate an area of blue shoreline. (It’s easier to change the color on a thick
area of shoreline.)

8. Click the shoreline with the tip of the flowing paint on Border Fill
bucket. If you click land or water by mistake, click the Undo button
(or choose Undo from the Edit menu) and try again.

...print a large map on multiple pages?
1. Choose Page Setup from the File menu. The Page Setup dialog box appears.
2. Click one of the choices (4, 9, 16, 25, or 36 pages) and click Print.

...place a map in a word processing document?

1. Open the map and choose Copy Map from the Edit menu. This copies
the map to your computer’s clipboard.

2. Open a document in a word processing program and move the cursor
to the place where you want your map to appear.

3. Choose Paste from the Edit menu to place the map in the document.

You can also export maps for use in word processing or page layout docu-
ments. See Export Maps for a Slideshow or the Internet on page 64.

MAPMAKER'S
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...search for historical maps?

In Find mode:

1. Click the Historical Maps button, or choose Historical Maps from
the Find menu.

2. Click one of the tabs to search for maps by location, date, or topic.

3. Scroll to the map you are looking for.

4. Click the map name, and click Display.

...create a title slide for my slideshow?
In Mapmakers Toolkit, do the following:

1. In Find mode, select Use Blank Map from the File menu. The program
presents a white map area in Draw mode.

2. Use the Text tool to create a title. If you wish, use the Standard Fill tool
to give the slide a background color other than white.

Save the file in case you need to edit it later.
Select Export As BMP (Slideshow) from the File menu.

Give the file a name other than the one you used in step 3 to save it.

Click Save.

AN A S

Then, in Mapmakers Slideshow, do the following:
1. Open your slideshow and click Add Slide.

2. Locate the title slide you exported as a BMP, and select it.
3. Click Open.
4

. If needed, drag slide to the desired position in the slide list.

...publish my map on the Internet?

The steps listed below assume that you already have an Internet service
provider (ISP) that offers space for users’ Web pages, and a working knowl-
edge of Hypertext Markup Language (HTML).

1. Use Mapmakers Toolkit to find and customize a map.

2. Choose Export As GIF from the File menu.

3. Give your file a name and click Save.
4

. Use the HTML editor to open the GIF file you exported and incorporate
it into your Web page.

MAPMAKRER'S
TOOLKIT




FEATURES & FUNCTIONS

MAPMAKER'S
TOOLKIT

...exchange maps between Macintosh and Windows versions of
Mapmaker’s Toolkit?

The maps you make on the Macintosh version of Mapmakers Toolkit can

be opened in the Windows version and vice versa.

Macintosh to Windows

1.

2.

Using the Macintosh version of Mapmakers Toolkit, save your map with
a period and the Windows three-character extension to the file name:
.mmt. For example, “My Map” on Macintosh must be named “My
Map.mmt” to view it in Windows.

Transfer the file to a Windows computer running Mapmakers Toolkit.

Note: If you transfer the file on a floppy disk, first format the disk for DOS. Your
Macintosh should recognize a DOS disk. Windows computers will not recognize
Macintosh-formatted disks.

3.

Start Mapmaker’s Toolkit on Windows and click Continue on the
title screen.

4. From the File menu, choose Open.

Locate the file, and click Open. The program may substitute Macintosh
fonts with Windows fonts.

Windows to Macintosh

1.

AN AN S i

7.

Using the Windows version of Mapmaker’s Toolkit, save a map as a
Mapmaker’s Toolkit-type file (*.mmt).

Transfer the file to a Macintosh computer running Mapmaker’s Toolkit.
Start Mapmaker’s Toolkit and click Continue on the title screen.

From the File menu, choose Open. A dialog box appears.

In the List Files of Type pop-up list, choose All Files.

Locate the file, and click Open. The program may substitute Windows
fonts with Macintosh fonts.

From the File menu, choose Save As to save the file in Macintosh format.

Getting Help

To access online help at any time, choose Help Contents from the Help menu.




FEATURES & FUNCTIONS

Finding Maps
In Find mode, you can access over 450 current and historical maps, including:

* 7 continents and 4 oceans

* 20 world regions

* 191 countries and 33 dependencies

* 50 U.S. states and Washington, D.C., and 5 U.S. regions
* 13 Canadian provinces and territories

* 125 historical maps (U.S. history, ancient civilizations, Middle Ages,
colonial era, twentieth century, and more)

* 48 theme maps (precipitation, land use, temperature, population
density, vegetation)

When you have opened the map you want, you can customize it to fit your
needs by turning on and off built-in layers such as political boundaries, rivers,
shaded relief (mountains and hills), place names, and cities. You can switch to
Draw mode to add your own text, color, and symbols. Finally, you can print
your map on one or multiple pages, save maps for Mapmaker’ Slideshow,
paste a map into a report or document, or publish your maps on the World

Wide Web.

Finding a Map

Find a Current Map

There are several ways to find the map you want. One way is by navigating
to it on the screen. When you launch Mapmaker’s Toolkiz, you see a map of
the world, with the continents and oceans labelled. If you pass the cursor
over each of these names, you'll see the arrow turn into a pointing hand,
indicating that these items are “hot-linked.” For example, if you want to see
a map of Africa, click “Africa” on the world map, and the continent of Africa
appears. Now you can click any of the country names to open a map of any
African country.

Note: 1o navigate to a continent, region, or country, both its boundaries and its
name must be turned on in the Layers dialog box. To find how to turn on map

layers, see page 41. @
You can also find current maps by clicking Current Maps on the toolbar, or C
by choosing Current Maps from the Find menu. The Find Current Map Mags

dialog box appears. You can locate the map you want by name or by location.
Current Maps button

MAPMAKRER'S
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Find Current Map

Name Tanatiun ]

Afghanistan
Africa
Alabama
Alaska
Albania
Alberta
Algeria
Andorra
Angola

Annnilla

M

K|

Display ] [ Cancel ]

Find Current Map dialog box

To find a map by name:

1. In the Find Current Map dialog box, scroll down the list until you see

the map you want.

2. Click the name to highlight it, then click Display.

3. The map you selected appears on the screen.

Alternatively, you can type the first few letters of the place name into the
text box, and the list will jump to the appropriate alphabetical location.

To find a map by location:

1.
2.

In the Find Current Map dialog box, click the Location tab.

You'll see an indented list of continents and oceans underneath the
“World” label. Places with a marker (a triangle on Macintosh, a plus sign
on Windows) to their left contain more maps underneath.

Click the marker to see the list of maps. Every place on the list, whether
it has a marker or not, represents a map. For example, you can click the
marker next to Asia to see a list of maps in Asia, or you can click the Asia
label itself and click Display to see a map of Asia.




Find a Historical Map

The historical maps included with the program have been organized into
three lists to make the maps easy to locate. Unlike current maps, you cannot
navigate to historical maps by pointing and clicking on the screen.

To find a historical map:
1. Click Historical Maps on the toolbar, or choose Historical Maps from
the Find menu.

2. The Find Historical Map dialog box appears. You can locate historical
maps by date, by location, or by topic.

By date: Click the marker next to the date range in which your map falls.
This opens a list of maps within that range. Then select the map you want
and click Display.

By location: Click the Location tab in the Find Historical Map dialog box.
Scroll through the list of locations until you find the map and year you want.
Select the map you want and click Display.

By topic: Click the Topic tab in the Find Historical Map dialog box. Scroll
through the list of topics to find the one you want. To open a topic, click the
marker to the left of the topic name. To view a map, select the map you want

and click Display.
Find a Theme Map

Theme maps are maps that have extra information (text, color, and/or
symbols) in addition to the maps’ standard physical and political features.
Mapmakers Toolkit comes with a set of theme maps, including the following
for six continents, the United States, and Canada:

Average January Temperature
Average July Temperature
Land Use

Population Density
Precipitation

Vegetation

To find a theme map:

1. Click Theme Maps on the toolbar, or choose Theme Maps from the Find
menu. The Find Theme Map dialog box appears.

2. Click the marker next to a topic (e.g., Vegetation) to see a list of the
available maps.

3. Click the name of the map you want and click Display.

Note: If you are having trouble accessing theme maps, please see the instructions

for locating the theme maps folder under Preferences on page 60.
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Additional Theme Maps

You can obtain specialized theme map sets that meet your curriculum needs.
To find out more, call Tom Snyder Productions at 800-342-0236 or 617-
926-6000. Or, visit the Tom Snyder Productions Web site at

www. TeachTSP.com.

Open a Saved Map

To open a map you've previously created and saved, choose Open from the
File menu. A dialog box appears, and you can navigate to the place where you
saved your map, select it, and click Open.

Note: Mapmaker’s Toolkit automatically switches to Draw mode when you open
a previously saved map.

The Open command can only be used to open Mapmaker’s Toolkit-type files.
If you saved your map as a PICT, BMP, or GIF image using the Export
command, you must use the Import command to open the file again. See
Import a Map below to find out more.

Import a Map

You can import any map into Mapmaker’s Toolkit as a “base map.” You can
then work in Draw mode to add text, color, and stamps onto the base. Before
you import a map:

1. Make sure the map is saved in a format that Mapmaker’s Toolkit can read,
including

* Windows Bitmap Format (BMP) — Windows and Macintosh versions
* Macintosh Picture Format (PICT) — Macintosh version only
* Graphics Interchange Format (GIF) — Windows and Macintosh versions

2. Make sure the map is 562 pixels wide by 360 pixels high, or smaller. If
your map is larger than 562 x 360 pixels the edges will be cropped. If the

map is smaller, it will appear with a white border.

3. In Find mode, choose Import from the File menu. In the dialog box,
locate the file you want to import, select it, and click Open. Mapmakers
Toolkit opens the map and automatically switches to Draw mode.

If you import a map that you previously exported from Mapmakers Toolkit,
you can add additional text, stamps, and color to the map, but you won't be
able to turn on or off any of the built-in layers that were available before you
exported the map.




Navigating in Find Mode

Back

Mapmakers Toolkit keeps track of every map you view. To go back to a
previous map, click Back on the toolbar, or choose Back from the Find menu.

Forward

Once you've clicked Back on the toolbar you can retrace your steps to the
most recently found map by clicking Forward, or by choosing Forward from
the Find menu.

For example, if you begin looking at the Connecticut map, then access the
Massachusetts map, and then Rhode Island, clicking Back from Rhode Island
brings you to the Massachusetts map again. Click Back again to see Con-
necticut, or click Forward to return to Rhode Island.

Navigation Maps

Navigation maps appear at the top of the screen in Find mode, and change

as you move from place to place. Navigation maps show you where you are in
the world, and you can click them to “zoom out” from your current location.

57 ] [t

Navigation Maps for Thailand

For example, find the map of Thailand. (Click Current Maps on the toolbar
and type “Thailand,” then click Display.) Above the map of Thailand you'll
see three navigation maps (from left to right): World, Asia, and Southeast
Asia. Click any of them to travel to one of these places.

Bookmarks

You can use bookmarks to quickly access the maps you use frequently.

To add a bookmark:
1. Find a current or historical map you want to bookmark.

2. Click Add Bookmark on the toolbar, or choose Add from the

Bookmarks menu.

To access your bookmarks:
1. From the Bookmarks menu choose Organize/Select. The Bookmarks
dialog box appears, showing a list of all your bookmarks.

2. You can go to a particular map by highlighting the bookmark for that
map and clicking Go to Map. The dialog box disappears, and the map

you selected appears on the screen.
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To organize your bookmarks:

1. From the Bookmarks menu choose Organize/Select. The Bookmarks
dialog box appears, showing a list of all your bookmarks.

2. Click New Folder. A folder appears, and you can type in a name.
Then you can drag and drop individual bookmarks into the folder. You
can even organize folders within folders, up to two levels deep. With this
feature, multiple users can keep their bookmarks separate by organizing
them in folders under their names.

3. To delete a bookmark or folder, highlight it and click Delete.

4. When you're finished organizing your bookmarks, click Done to go back
to Find mode.

Bookmarks

& Bookmark List New Folder
b £ Mrs. Spencer's Bookmarks '
< £ Mr. O'Neil’s Bookmarks

4 Argentina

4 Canada

4 China Go to Map

4 United Kingdom

Bookmarks folder

Return to the World Map

To quickly return to the world map, choose New from the File menu.

Switch to Draw Mode

When you have found the map you want to work with, you can customize
it with your own color, text, and stamps in Draw mode.

To switch from Find mode to Draw mode, choose Go To Draw from the File
menu, or click the Draw tab on the left side of the screen.

Note: You can turn the built-in layers on and off in either Find or Draw mode,
but you can only add your own features to a map in Draw mode.

BN CEAWY FiND \

Find & Draw tabs
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Customizing Maps

Once you have found a current or historical map in Find mode, you can
switch to Draw mode to add your own color, text, and stamps to the map.
The Border Fill feature lets you fill each boundary area displayed on the map
with color. In addition, there are over 800 stamps in 30 categories, including
animals, crops, transportation, and flags of the world. With these powerful
tools, you and your students can customize any map to illustrate a lesson,
report, or presentation.

Choosing the Map Layers

Each map contains several layers of physical features (rivers, relief, longitude-
latitude grid) and political features (boundaries, place names, cities) that can
be turned on or off. In addition, you can customize your map with “My
Features” (text, stamps, border fill, and drawn items) in Draw mode.

To turn layers on and off:

1. Click the Layers button in the upper right corner of the screen, or choose
See Layers from the Options menu.

2. A dialog box appears listing all the layers available for the map you
are viewing.

3. To turn a layer on, click its name. The layer is on when a check mark
is visible. To turn the layer off, click the item again, and the check mark
disappears. You can easily choose to display all the layers by clicking All,
or none of the layers by clicking None.

4. When you've selected the layers you want, click Apply. You'll see the map
beneath the dialog box modified to your specifications. If you want to
make more changes, you can continue to check or uncheck boxes in the
Layers dialog box until you are satisfied.

5. When you have finished, click OK.

Note: 1o navigate to a continent, region, or country in Find mode, both its
boundaries and its name must be turned on in the Layers dialog box.
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California map and California Layers dialog box

Keep in mind that there are some layers that are only available on certain
maps. For example, the National Parks layer is only available on some coun-
try maps. The chart on the next page illustrates which layers are generally
available for which maps. My Features are only available in Draw mode.

Note: In Draw mode, you can turn layers on or off at any time, even after you
have added your own features to the map.

Order of Map Layers

In Draw mode, things you add to the map (text, stamps, or paint) cover some
of the built-in layers. Other built-in layers always remain on top of items you
add. In general, lines, shapes, and border fill you add to the map cover the
map’s built-in base, subject highlight, and relief. Rivers, boundaries, and
standard map text remain on top of these elements. Text or stamps you add
to the map cover all built-in layers. The layers appear as follows, from top to
bottom.

User Text

Stamps

Built-in Text

Boundaries

Rivers

Draw Items (lines, shapes, color)

Border Fill

Relief

Subject Highlight

Base
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Layers Available in Find or Draw Mode

Political Features

Subject Highlight ° ° ° ° ° °
State/Province Boundaries ° ° °
State/Province Names . ° °
Region Boundaries ° ° °

Region Names ° d o
International Boundaries [ [ ° o ° ° °
Country Names ° . ° ° ° ° °
Island Names L o ° ° ° ° °
Continent Names ° ° ° ° °

Cities ° ° .
Physical Features

Relief ° ° ° ° ° ° °
Park Names ° °
Rivers ° ° ° . ° °
River Names ° ° ) ° ° °
Grid ° ° ° ° ° ° °
Title ° L] o o (] (] °
Water Body Names ° ) ° ° ° ° °
My Features

Draw ° ° ) ) ° ° °
Stamps ° ° ° ° ° ° °
Text ° [ ° ° ° ° °
Border Fill o i 4 4 ° o [

Map Layers available by type of map
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Drawing on Your Map

In Draw mode, Mapmakers Toolkit offers several drawing tools you can use to
illustrate your map. With each tool, you also have a choice of 33 colors.

Marquee tool
Select and move lines
and shapes you have
drawn on the map. Pencil tool
Draw freehand lines.
Line tool
Draw straight lines.
Ellipse tool
Draw ellipses.
Rectangle tool
Draw rectangles.
Eraser tool
Erase lines and shapes
Standard Fill tool you have drawn.
Fill in shapes I

you have drawn. Border Fill tool

Fillin any political area on

Selection tool the map.
Select text and
stamps you have

added to the map.

Text tool
Add text
to the map.

Stamp tool
Add stamps
to the map.

Undo tool
Undo the last action
you performed.

Tools that work in similar ways are grouped together:

Marquee Border Fill | Selection | Undo
Pencil Text
Line Stamps
Ellipse
Rectangle

Eraser

Standard Fill
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Draw a Line

There are two ways to draw lines in Mapmaker’s Toolkit. You can draw free-
hand lines with the pencil tool, or straight lines with the line tool.

To use the pencil tool:
1. In Draw mode, click the Pencil icon on the toolbar.

2. Choose a size and shape for your line by clicking one of the options at
the top of the screen. You can choose a square shape of 1, 2, 4, 6, or 8
pixels, or a round shape of 6, 8, or 10 pixels.

3. Choose a color for your line by clicking a color on the color palette at
the top of the screen. The color you have selected is displayed in the
rectangular area to the right of the palette.

4. Click and drag with the mouse to create a line.

To use the line tool:
1. In Draw mode, click the Line tool on the toolbar.

2. Choose a width and style for your line by clicking one of the options at
the top of the screen. You can choose a line width of 1, 2, 4, 6, or 8
pixels, and a solid, dotted, or dashed style.

3. Choose a color for your line by clicking a color on the color palette at
the top of the screen. The color you have selected is displayed in the
rectangular area to the right of the palette.

4. Click and drag with the mouse to create a line.
If you make a mistake, click the Undo button on the toolbar, or choose Undo

from the Edit menu. You can also select the line using the Marquee tool, then
choose Delete from the Edit menu.

Note: You can move lines or shapes after you have drawn them using the Marquee
tool. See Select and Move an Item on page 47 for more information.
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To create a circle or square,

=

Rectangle tool
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Ellipse tool
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the shape tools.

aed

Standard Fill tool

Draw a Shape

You can draw elliptical or rectangular shapes on your map using the ellipse and
rectangle tools. These shapes can be empty, or filled with any color you choose.

To draw a shape:
1. Click the Rectangle or Ellipse tool on the toolbar.

2. Choose a width for the border of your shape by clicking one of the
options at the top of the screen. You can choose a width of 1, 2, 4, 6,
or 8 pixels.

3. Choose a color for the border of your shape by clicking a color on the
color palette at the top of the screen. The color you have selected is
displayed in the rectangular area to the right of the palette.

4. Click and drag with the mouse to create a shape.

If you make a mistake, click the Undo button on the toolbar, or choose Undo
from the Edit menu. You can also select the shape using the Marquee tool,
then choose Delete from the Edit menu.

Fill in a Shape

The Standard Fill feature lets you fill in a shape you have created using the
Rectangle or Ellipse tools.

To fill in a shape:
1. Click the Standard Fill tool on the toolbar.

2. Choose a fill color by clicking a color on the color palette at the top
of the screen. The color you have selected is displayed in the rectangular
area to the right of the palette.

3. Move the paint bucket cursor anywhere inside the shape and click.
The shape fills with the color you selected.

4. If you accidentally click outside of your shape, the whole map will fill.
To undo this, click the Undo button on the toolbar, or choose Undo
from the Edit menu.

Note: The Standard Fill tool fills only shapes you have created with the Rectangle
or Ellipse tool. 1o find out how to fill political boundaries, see Filling in
Boundaries on page 49.




Select and Move an Item

The Marquee tool allows you to select and move lines, ellipses, rectangles,
and other items you've placed on your map. Text and stamps are selected
and moved using the Selection tool (see page 53).

To select and move an item using the Marquee tool:
1. Click the Marquee tool on the toolbar.

2. Drag the crosshairs over the item you wish to select. The tool forms

a dashed shape.

3. Note that when you pass the cursor over the selected area, the cursor
becomes an arrow, indicating that you can move the item. Drag the
item anywhere you want on the map, and release the mouse button
when you're ready to place the item. You can place the selected item
more precisely by using the arrow keys on your keyboard to move it
one pixel at a time.

4. To deselect the item, click anywhere outside of it on the map.

When you use the Marquee tool, everything inside the dashed area will be
moved. To select an item more precisely, you can change the shape of your
Marquee tool by clicking one of the shapes that appear at the top of the
screen. There are three choices:

Rectangle: This is the default. With it you can draw a rectangular shape
around the item you wish to select. To draw a square, hold down the Shift
key while dragging the crosshairs.

Ellipse: With the ellipse, you can draw a circle or oval shape around the item
you wish to select. To draw a circle, hold down the Shift key while dragging
the crosshairs.

Lasso: The lasso lets you draw a freehand shape around the item you wish

to select. If you do not return to the starting point, this tool completes it for
you by drawing a straight line from the starting point to the ending point.

To select all lines and shapes you have added to the map:
1. Click the Marquee tool.
2. Choose Select All from the Edit menu.

3. A dashed marquee appears around the entire map. You can click and drag
to move all the lines and shapes at once, or choose Delete from the Edit
menu to delete all lines and shapes. Border fill, text, and stamps you have

added will not be affected.
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Clone (Duplicate) an Item

To duplicate a line or shape you have drawn:

1. Select the item using the Marquee tool.
2. Choose Clone from the Edit menu.

3. A duplicate of the item appears. The original item is deselected and the
new item is now inside a marquee selection.

4. To move the new item, position your pointer inside the marquee selection
and click and drag the item to the desired location.

5. Ifyou do not wish to move the new item, click anywhere outside it.
The item is deselected and is now on top of the original item.

Resize an Item

To resize a line or shape you have drawn on your map:

1. Select the item using the Marquee tool.

2. Choose Scale Item from the Edit menu. The Scale Marquee dialog
box appears.

3. Click the size you want. You can scale your item by 25, 50, 75, 150 or
200 percent, or you can click Other and type in any percentage between
25 and 200. Click Apply to see the change take place.

4. To reset your item back to its original size, click Restore (100%). You can
restore an item to it’s original size even after you close the Scale Marquee

dialog box, as long as you do not deselect the item.
5. When you are satisfied with the item’s size, click OK.
Note: You can only resize lines and shapes you have drawn, or images

youve copied to the map from another drawing program. You cannot resize
text or stamps.

Delete an Item

There are several ways to fix a mistake or delete an item you have drawn
on your map. (Note that the Eraser and the Marquee tools work on lines
and shapes only, not text, stamps, or border fill.)

Undo
B l Click Undo on the toolbar or choose Undo from the Edit menu to undo

something you just did. This works only on the last action you performed.
Undo button
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Eraser

With the eraser tool, you can delete lines or shapes you have drawn

pixel by pixel.

To use the eraser tool:
1. Click the Eraser tool on the toolbar.

2. Choose a size for your eraser by clicking one of the options at the top
of the screen. The eraser can be 1, 6, 12, or 18 pixels.

3. Click and drag the eraser through the area you want to erase.

4. If you accidentally erase something, click Undo on the toolbar or choose
Undo from the Edit menu.

Marquee

To select and delete a line or shape you have drawn, select it using the
Marquee tool, then choose Delete from the Edit menu. Remember that
everything within the marquee will be deleted. (See page 47 for information
on how to select an item with the Marquee tool.)

Filling in Boundaries

You can add color to any area enclosed by political boundaries, including
states, provinces, regions, countries, and continents. You can also fill in water
bodies and the shoreline.

When you fill a country or other political area, the Border Fill tool will also
fill non-contiguous areas (for example, it will fill Alaska and Hawaii when
you fill the continental United States). Whether you want to show Union
and Confederate states during the U.S. Civil War; create a map of major
world religions; or make a blank outline map, the Border Fill tool can help
you do these and much more.

To fill in the borders of your maps:
1. Click the Border Fill tool on the toolbar.

2. Choose a color for the border fill by clicking a color on the color palette
at the top of the screen. The color you have selected is displayed in the
rectangular area to the right of the palette.

3. Click inside the area you want to fill. Note that islands and other non-
contiguous territory are filled as well.
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To quickly erase border fill
on the entire map, turn off
all layers but Border Fill, then
click on the map using the
Border Fill Eraser.

Border Fill Eraser
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A |

Text tool

As a general rule, when there is more than one boundary layer showing,

the Border Fill tool will fill the smallest visible political area. For example,

on the United States map, if you use the Border Fill tool when international,
regional, and state boundaries are all turned on, it will fill individual states.
To fill regions, you must open the Layers dialog box and turn off the State
Boundaries layer. Once the state boundaries are no longer showing, the
regions become the smallest political areas on the map, and they will be filled
when you use the Border Fill tool. By experimenting, you'll soon discover
that there are many ways to fill areas with color.

To remove color added with the Border Fill tool:

1. Click the Border Fill tool on the toolbar.

2. Click the Border Fill Eraser at the top of the screen.

3. Click inside the area from which you want to remove the color.

The border fill in that area disappears.

Note: The Border Fill Eraser will erase only border fill. It will not erase lines,
shapes, text, or stamps you have added to the map.

Have fun experimenting on your own with the Border Fill tool.

Adding Text and Stamps to Your Map

Add Text to your map

With the Text tool, you can add labels, a title, and other text to your map. The
Text tool allows you to choose the color, style, size, and position of your text.
To add text to your map:

1. Click the Text tool on the toolbar, then click anywhere on the map.
The Text Tool dialog box appears.

2. Type your text into the text box. To find out about formatting your text
in the Text Tool dialog box, see Format Text on the next page.

3. Click OK. Your text appears on the map.

Note: See page 53 to find our about moving text on your map using the
Selection rool.
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Format Text

The Text Tool dialog box allows you to customize your text by formatting it
in a variety of ways. The “Sample” text in the dialog box shows you how the
formatted text will look. To change the formatting of text you have already
placed on the map, click the Text tool on the toolbar, then double-click the
text you want to format. This selects the text and opens the Text Tool dialog
box, where you can change the formatting.

TextTnl ="—"———————————
Font Size Text
| Helvetica ~| [12 «] | B
Alignment Style Rotation ° —~
= =15 3]z g
P

Sample
3 A [l I
Color
i Box =
) Background (] Transparent

Text Tool dialog box

Use the Text Tool dialog box to format text in these ways:

Font

Use the pop-up menu to choose fonts installed on your computer.
Size

Use the pop-up menu to choose a size for your text.

Alignment

Choose flush left, centered, or flush right.

Style

Choose bold, italic, or underlined, or any combination of the three.

Rotation

Place your text vertically or at an angle by selecting one of the four choices
from the pop-up menu.
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Color

Choose a color for your text by clicking a color on the color palette.
The color you have selected is displayed in the rectangular area to the
right of the palette.

You can color the text box and the background separately by clicking “Box”
or “Background,” then clicking a color on the color palette. If you do not
want a text box or background, click Transparent.

When you finish formatting your text, click OK. The text appears on the map.

Add Stamps to Your Map

Mapmakers Toolkit provides many stamps with which you can illustrate maps.
The stamps are organized into the following sets:

Animals Minerals & Energy
Arrows Numbers (large and small)
Crops People

Disasters Religions

Flags (for every country) Sports

Habitats Transportation
Industries War

Letters (large and small) Weather

Markers (circles with dots, circles,
flags, pins, squares, stars, triangles)

To add a stamp to your map:

1. Click the Stamp tool on the toolbar. At the top of the screen, a row of
animal stamps appears.

2. Choose a stamp set from the pop-up menu.

3. Use the arrow markers to the left of the stamps to scroll through all the
stamps available in that set. Alternatively, you can see all the stamps at
once by clicking the plus sign to the right of the stamps. In the dialog
box, you can then choose a row and click Select to display that row.

4. Pass the cursor over any stamp to see its name displayed in the text box.

5. When you have found a stamp you want, drag it from the top of the
screen and place it on the map.

Stanip Set Stamps
[ 1
[ Animals | fv W W W f{g W A
% C‘ﬁ::‘ =
[alpaca | % F-]
Stamp Name Scroll Arrows See All in Set

Stamp tool options




Select and Move Text or Stamps

The Selection tool allows you to select and move both text and stamps you've
placed on your map. You can also move text with the Text tool, and stamps
with the Stamp tool.

Note: The Selection tool does not work on lines, circles, and rectangles you have
drawn. Those elements can be selected using the Marquee tool (see page 47).
To select text or stamps:

1. Click the Selection tool on the toolbar. (You can also select text with the
Text tool and stamps with the Stamp tool.)

2. Position the pointer on top of the item you wish to select.
3. Click to select the item. An item is selected when it has a red box

around it.

You can select multiple items by holding down the Shift key on the keyboard
while you click the items you want to select. Each selected item has a red box
around it.

To move text or stamps:

1. Select the item or items you want to move using the Selection tool.

2. Drag the item or items to a new location and release the mouse button.
You can position an item more precisely by using the arrow keys on the
keyboard to move it one pixel at a time.

To select all stamps you have added to the map:

1. Click the Stamp tool.

2. Choose Select All from the Edit menu.

3. A red box appears around each stamp you have added to the map. You
can click and drag to move all the stamps at once, or choose Delete from

the Edit menu to delete all stamps. Lines and shapes you have added will
not be affected.

To select all text you have added to the map:

1. Click the Text tool.

2. Choose Select All from the Edit menu.

3. A red box appears around each text item you have added to the map.
You can click and drag to move all the text at once, or choose Delete

from the Edit menu to delete all text. Lines and shapes you have added
will not be affected.

Note: If you click the Selection tool, then choose Select All, you will select all text
and stamps at the same time.
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Clone (Duplicate) Text or Stamps

To copy text or stamps you've placed on your map:

‘ I 1. Select the item you wish to copy using the Selection tool.

Selection 1ol 2. Choose Clone from the Edit menu.

3. A duplicate of the item appears. The original item is deselected and the
new item has a red box around it, indicating that it is selected.

4. To move the new item, position the pointer on top of it and click and
drag the item to the desired location.

5. Ifyou do not wish to move the new item, click anywhere outside it to
deselect it.

Delete Text or Stamps

To delete text or stamps from your map:

1. Select the item you wish to delete using the Selection tool.

2. Choose Delete from the Edit menu.

You can also click Undo on the toolbar or choose Undo from the Edit menu to
undo something you just did. This works only on the last action you performed.

Add Your Own Pictures to a Map
Mapmakers Toolkit allows you to copy images from other software programs

and paste them into your map.

Note: When you copy images from other sources, such as encyclopedias or the

Internet, be sure to name the source in small type next to each image.

To paste an image onto your map:

1. Inadrawing or painting program, select the item you wish to copy and
choose Copy from the Edit menu.

2. In Mapmaker’s Toolkit, make sure you are in Draw mode.

3. Choose Paste from Clipboard from the Edit menu.

Your image now appears on the map. Drag the image to the desired location.
If you want to select the image later, you can select and move it using the
Marquee tool. You can also resize the item the way you would other lines and
shapes on your map. See Resize an Item on page 48 for more information.
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Building a Legend
A powerful feature of Mapmaker’s Toolkit is the ability to automatically build
a legend for your map.

Open the Map Legend

To access the map legend in Find mode or Draw mode:

1. Click the Legend button in the upper right corner of the screen or choose
Show Legend from the Options menu. The Legend dialog box appears.

2. The legend shows standard items included on maps in the program. You
cannot edit the legend in Find mode. To find out how you can edit the
legend in Draw mode, see Customize the Map Legend below.

3. When you are finished looking at the legend, click OK.

Note: The legend shows all standard map features, whether or not those layers are
turned on.

Customize the Map Legend

In Draw mode, you can customize the map legend to suit your needs.

Legend
International, State, or Regional Boundar __ _ Disputed or
Prowvinzial Boundary 9 d Water Boundary
Fs
River Map Subject Area FPark
. . State or Provincial .
#  Mational Capital ()] Capital » City
-
w Desert area ﬂ FMountian region Neutral Territory
[ update | | Hide Basic Legend | [ Delete | [ AddSymbal | ok |
[ShowEBasiclegend | [ EditText |

An edited map legend

To edit the map legend:

1. In Draw mode, open the Legend dialog box by clicking the Legend
button in the upper right corner of the screen, or by choosing Show
Legend from the Options menu.

2. In the Legend dialog box, click Build Legend. A number of choices
appear at the bottom of the dialog box.

FEATURES & FUNCTIONS
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Legend button

To quickly access
the Legend Builder,

choose Build Legend
from the Options menu.
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3. Click Update. The legend will update to include any color or symbol
youve added to the map. If there are more than 12 entries in the legend,
click the down arrow to see more items. Click the up arrow to go back to

the top of the legend.

You can edit the legend in the following ways:

Edit Text

To change the text of any entry, click the entry to select it and click Edit Text.
In the Legend Entry Text dialog box, type the new text for the entry. You are
limited to two lines, and 25 characters per line. When you're done, click OK.
The new text now appears in the legend. Occasionally, text may be too long
to fit on one line in the legend, even though it is less than 25 characters.
When this happens, edit the text to appear on two lines instead of one.

Hide the Basic Legend

To hide the items included in the standard legend, click Hide Basic Legend.
The entries disappear, and will not print when you print the legend. To make
the standard legend visible again, click Show Basic Legend.

Delete an Entry

To remove an item from the legend, click the entry to select it and click
Delete. The entry is removed from the legend. You can delete items from
the standard legend. Click Show Basic Legend to show all standard legend
items again.

Add a Symbol

You can add a symbol to the legend that does not appear on the map.

To add a symbol, click an empty legend item to select it, and click Add
Symbol. The Select Stamp dialog box appears. You can now choose a stamp
from any stamp set to add to your legend. Use the pop-up menu to see a list
of the stamp sets. When you find a symbol you want to add, click it to
highlight it, and click Select. The symbol now appears in your legend.

Move Legend Entries

You can rearrange entries in the legend by dragging and dropping them into
the desired location. If you drop an entry into a slot where another entry has
already been placed, the two entries will switch places. The order in which
entries are displayed on the screen is the order in which they will print.
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Save the Legend

You do not need to do anything special to save your legend. Simply click OK
when you are finished editing. The Legend dialog box closes. If you reopen
the legend, it still reflects the changes you have made. If you have added
anything new to your map, click Update to add those items to the legend. If
you save your map, any changes to the legend are also saved.

Note: If you have added or deleted entries in the legend, and then you click
Update, the legend will revert ro display what is on the map. Updating the legend
does not alter any text changes you have made.

Legend Reminder

The Legend Reminder is a feature that will notify you when you save your
map that the legend has not been updated with new information. To turn on
the Legend Reminder, choose Preferences from the Edit menu. In the Prefer-
ences dialog box, click Legend Reminder. A check mark appears in the box,
and the Legend Reminder is turned on. Click OK. If you want to turn it off
again, click Legend Reminder again in the Preferences dialog box. The check
mark disappears, and the Legend Reminder is off. The program default is for
the Legend Reminder to be off.

Saving Maps

Save a Map

While working in Draw mode, you can save your map at any time to return
to later and continue working. When you save your map any changes you
have made to the map legend will also be saved.

To save your map:

1. Choose Save from the File menu. If you have not previously saved your

map, a dialog box appears.
2. In the dialog box, navigate to the place where you want to save your map.

3. In the text box, type a name for your map.

4. Click Save.

MAPMAKRER'S
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To save your map with another name:
1. Choose Save As from the File menu. A dialog box appears.

2. In the dialog box, navigate to the place where you want to save
your map.

3. In the text box, type a new name for your map.

4. Click Save.

Using the Save or Save As commands saves your map as a Mapmaker’s
Toolkit-type file, which can only be opened by Mapmakers Toolkit. To save
files in a format (PICT, BMP, or GIF) that can be read by other programs,
you must use the Export command. You can export maps in either Find or
Draw mode. To find out how to export a map, see Export Maps for a Slide-
show or the Internet on page 64.

Save a Map to the Clipboard

You can save your map to the computer’s clipboard to paste into a word
processing or painting document.

1. Open the map and choose Copy Map from the Edit menu. This copies

the map to your computer’s clipboard.

2. Open a word processing or painting program and move the cursor to the
place where you want the map to appear.

3. Choose Paste from the Edit menu to place the map in the document.

If your word processing or painting program has an Import feature, you can
export your map from Mapmaker’s Toolkit, then import it into the word
processor (see Export Maps for a Slideshow or the Internet on page 64).

Switch to Find Mode

To switch from Draw mode to Find mode, choose Go To Find from the
File menu, or click the Find tab on the left side of the screen. If you have
not saved the map you were working on, you will be prompted to do so
before the program switches to Find mode. Work that is not saved at this
time will be lost.




Mapmaker’s Toolkit Options

Open a Blank Map (Find Mode only)

To open a blank screen on which you can draw your own map, choose Use
Blank Map from the File menu. This option is accessible only in Find mode.
Mapmakers Toolkit will switch to Draw mode, and present the drawing tools
and a white map area. Go to town!

Zoom In/Zoom Out (Draw Mode only)

In Draw mode, you can enlarge the map to look at it more closely. This
is helpful when you are trying to draw in a small area or position an
item precisely.

To enlarge the map, click the Zoom In button at the bottom left corner of
the map or choose Zoom In from the View menu. You can enlarge by 200
or 400 percent.

To reduce the map again after you have enlarged it, click the Zoom Out
button at the bottom left corner of the map or choose Zoom Out from the
View menu.

Note: Using the Zoom tool to enlarge your map will not make the map print
bigger. To print maps in large sizes, see Print a Map on Multiple Pages on page 61.

Sound

To turn the program’s sounds on or off, choose Sound from the Options
menu. A check mark indicates that the sound is on. To turn the sound off,
choose Sound from the Options menu again. The check mark disappears and
the sound is off.

Preferences

During installation of Mapmakers Toolkit, the theme maps are copied from
the CD-ROM onto your computer’s hard drive. Theme maps are installed
into the “Themes” folder, which is usually located in the Mapmaker’s Toolkit
folder along with the Mapmaker’s Toolkit program.

FEATURES & FUNCTIONS

Use this feature to create
title screens for your slideshow.

See Create a Title Slide
on page 68.
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If you move the “Themes” folder after installation, you may need to indicate
its new location before you can access the theme maps.

To do this:

1. In Find mode, choose Preferences from the Edit menu. The Preferences

dialog box appears.

2. Click Browse and navigate to the place where the “Themes” folder
is located.

3. Highlight the “Themes” folder and click Select.
4. The Preferences dialog box displays the correct path to the folder. Click OK.

Preferences

Location of themes folder m

|Marvin:Mapmaker's Toolkit f:datathemes; | [ Browse |
_Cancel |

[J Prompt to Update Legend

Preferences dialog box

If the Legend Reminder is turned on, you will be reminded each time you
save your map that the legend has not been updated with new information.
To turn on the Legend Reminder, click Legend Reminder in the Preferences
dialog box. A check mark appears in the box, and the Legend Reminder is
turned on. Click OK. If you want to turn it off again, click Legend Reminder
again in the Preferences dialog box. The check mark disappears, and the
Legend Reminder is off. The program default is for the Legend Reminder

to be off.

Quit/Exit Mapmaker’s Toolkit

To close Mapmaker’s Toolkit, choose Quit or Exit from the File menu. If you
are in Draw mode and have not saved the map you were working on, you will
be prompted to do so.




Publishing Maps
When you have finished designing your masterpiece, Mapmaker’s Toolkit

makes it easy to publish your map in print, or electronically with Mapmaker’s
Slideshow or on the Internet.

Printing Maps

Print a Map on One Page

The Mapmaker’s Toolkit default is to print a map on one page, with no
legend. To find out about printing a map with a legend, see Print a Map with
a Legend on page 62.

1. Choose Print from the File menu. This opens a print preview dialog
which allows you to see how your map will look on the page. (Macintosh
users printing for the first time will see the Printer Setup dialog box. To
print the map at the maximum possible size on one page, change the
paper orientation to landscape/horizontal, and click OK.)

2. You can enlarge the map to look at it more closely by clicking Zoom In,
or by holding the cursor (shaped like a magnifying glass) over the map
and clicking. You can view the map at 200 and 400 percent.

3. To zoom out again, click Zoom Out.

4. Click Print if you would like to print the map as it is shown. Otherwise,
click Close.

5. If you choose to print, the Print dialog box appears where you can choose
to print multiple copies, manual feed, and so on. Click Print (Macintosh)
or OK (Windows) to send your map to the printer.

Note: Enlarging the map with the Zoom tool will not make it print bigger.
10 print maps in a large format, see Print a Map on Multiple Pages below.

Print a Map on Multiple Pages

You can print your map on 4, 9, 16, 25, or 36 pages, which you then tape

or glue together. To print a map on multiple pages:

1. Choose Page Setup from the File menu. The Page Setup dialog box appears.
2. Click one of the choices (4, 9, 16, 25, or 36 pages).

3. Click OK to save the setup and continue working on your map, or click
Print Preview to see how your map will look on each page.

4. In the Print Preview dialog box, click Next Page to view each page.
You can go back by clicking Previous Page. To see two pages at once,

click Two Pages.

FEATURES & FUNCTIONS
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When printing on multiple pages,
it's best to use landscape (horizontal),
not portrait (vertical), paper orientation

to avoid wasting paper. (The default
orientation is landscape.)
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When printing a multiple-page

map, choose to print the legend
on a separate page.

tip
When you print the legend

on the same page as the map,
the map will be reduced in size

to fit all the legend items on
the page. To avoid this, change
the paper orientation to portrait.
This allows you to fit more legend
items on the page without greatly

reducing the size of the map.
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5. You can enlarge the map to look at it more closely by clicking Zoom In,
or by holding the cursor (shaped like a magnifying glass) over the map
and clicking. You can view the map at 200 and 400 percent.

6. To zoom out again, click Zoom Out.

7. Click Print if you would like to print the map as it is shown. Otherwise,
click Close and go back to Page Setup.

8. If you choose to print, the Print dialog box appears where you can choose
to print multiple copies, manual feed, and so on. Click Print (Macintosh)
or OK (Windows) to send your map to the printer.

Print a Map with a Legend

Mapmaker’s Toolkit lets you print the map legend on the same or a separate page.

1. Choose Page Setup from the File menu. The Page Setup dialog box appears.

2. In the legend area of Page Setup, click On to print the legend with
your map. It will print at the bottom of the page.

3. Click Separate Page to print your legend on another sheet of paper.

4. If you want to print your map on multiple pages, click one of the choices.
Note that the legend will print on a single page, even if you have chosen
to print your map on multiple pages.

5. You can click OK to save the setup and continue working on your map.
Or you can click Print Preview to see how your map will look on each page.

6. In the Print Preview dialog box, click Next Page to view each page. You
can go back by clicking Previous Page. To see two pages at once, click
Two Pages.

7. You can enlarge the map to look at it more closely by clicking Zoom In,
or by holding the cursor (shaped like a magnifying glass) over the map
and clicking. You can view the map at 200 and 400 percent.

8. To zoom out again, click Zoom Out.

9. Click Print if you would like to print the map as it is shown. Otherwise,
click Close and go back to Page Setup.

10. If you choose to print, the Print dialog box appears where you can choose
to print multiple copies, manual feed, and so on. Click Print (Macintosh)
or OK (Windows) to send your map to the printer.
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Africa Precipitation theme map printed with legend

Change the Paper Orientation

The Mapmaker’s Toolkit default is landscape (horizontal) orientation in
Windows, and portrait (vertical) orientation for Macintosh. To change the
paper orientation:

1. Choose Page Setup from the File menu. The Page Setup dialog box appears.
2. Click Printer Setup.

3. In the Printer Setup dialog box, click the portrait (vertical) paper orientation.

Macintosh users:

The first time you print a map in Mapmaker’s Toolkit, the Printer Setup dialog
box appears automatically. Here, you can set the paper orientation to land-
scape (horizontal). This allows the map to print at the maximum possible size
on one page. To change these settings again later, follow the instructions above.

Add a Map to a Document

You can add your map to a report or document that you've prepared in a

word processing or page layout program.

1. Open the map and choose Copy Map from the Edit menu. This copies
the map to your computer’s clipboard.

2. Open a document in a word processing program and move the cursor to
the place where you want the map to appear.

3. Choose Paste from the Edit menu to place the map in the document.

If your word processing program has an Import feature, you can export your
map from Mapmakers Toolkit, then import it into the word processor (see

Export Maps for a Slideshow or the Internet on page 64). m
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Electronic Publishing

Mapmakers Toolkit makes it easy to publish your maps electronically. With
Mapmaker’s Slideshow, you can use your computer to present your maps in an
electronic slideshow. For example, you could create maps of the major crops
in each region of Africa, or document the events leading up to the Civil War,
and present them in a slideshow. You can also save your maps in a format

suited to publishing on the World Wide Web.

Export Maps for a Slideshow or the Internet

The Export command allows you to save your map in a format that can be
used by Mapmaker’s Slideshow, by word processing and painting programs,
and by HTML (Hypertext Markup Language) editors for use on the World
Wide Web.

To export a map:

1. Locate the map you want to export.

2. From the File menu, choose Export. You have a choice of sub-menus that
allow you to export your file as a BMP, GIE or PICT (Macintosh only).
The chart below will help you determine which format you'll need.

3. Name the file and click Save.

m e Chel+M
:E‘:" Find N Goto Draw
o to Fin
open... %0 Open... Chel+01
gave A #5 |mpart....
A P Sdshon.
Uze Blank Map Az GIF...
Import...
As BMP {Slideshow)... | Page Setup..
[ Erint Chil+P
Page Setup...
Print... *P
Quit %Q Ext
File...Export Menu (Macintosh) File...Export Menu (Windows)
Export for... Macintosh | Windows
Mapmaker’s Slideshow BMP* BMP
Word processor PICT BMP
Painting or drawing program |PICT BMP
HTML (World Wide Web) GIF GIF

* It’s best to save maps you'll use in Mapmaker’s Slideshow in BMP format,
even if you are using a Macintosh.
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When you export a map in this manner, you will no longer be able to turn
the map layers on and off if you open the map again in Mapmaker’s Toolkit.
If you want to be able to return to the map and make changes later, you
should save it as a Mapmaker’s Toolkit-type file before exporting it in another
format. To find out how to save a map, see Save a Map on page 57.

Mapmaker’s Slideshow

Mapmakers Slideshow, a separate program that comes with Mapmaker’s
1o0lkit, allows you to put on a slideshow presentation of your maps. To open

Mapmakers Slideshow:

For Macintosh: Double-click the Mapmaker’s Slideshow icon in the
Mapmakers Toolkit folder located on your computer’s hard drive.

For Windows: Go to the Start menu in Windows. Within the Programs
folder you'll find a Mapmakers Toolkit folder. Select Slideshow
to launch the program.

A sample slideshow is included on the CD-ROM, to give you an idea of the
various features of Mapmaker’s Slideshow. To run the sample slideshow:

1. On the Mapmaker’s Slideshow main menu, click Open.
2. Navigate to the Sample Slideshow folder on the CD and double-click the
Sample Slideshow file.

3. Click Run Slideshow. The slideshow begins, and the slides will advance
automatically. To stop the slideshow at any time, press the Escape (Esc)
key on your computer’s keyboard.

If you wish to modify the Sample Slideshow, first copy it to your computer’s
hard drive.

Create a New Slideshow

To begin creating a new slideshow:

1. Open Mapmakers Slideshow by double-clicking the Mapmaker's Slideshow
icon in the Mapmaker’s Toolkit folder.

2. On the Mapmakers Slideshow main menu, click New. The New Slide-
show Setup dialog box appears.

Mapmaker's Slideshow main menu

FEATURES & FUNCTIONS

Mapmaker's Slideshow icon

Before you begin to create
your own slideshow, make sure
that you have exported all the
maps you want to use in the
slideshow in BMP format. To find

out how to export maps, see
Export Maps for a Slideshow
or the Internet on page 64.
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slideshow you make.
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Note: When you save your slideshow, any slides and sounds you gathered from
other folders on your computer or from network folders will be copied into the
slideshow folder. Its important that all these files remain in the same folder for
the slideshow to run properly.

3. To create a new folder in which to save your slideshow, slides, and
sounds, click Create. Follow the on-screen instructions to choose a name
and location for your folder, and for your slideshow.

4. If you want to save items in a folder that already exists, click Select.

After you create or select a folder for your slideshow, the Mapmaker’s
Slideshow main screen appears. You are now ready to begin working
on a slideshow.
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Mapmaker's Slideshow main screen

Add a Slide
To add a slide to your slideshow:

1. Click Add Slide. The Add Slide dialog box appears.

2. Navigate to the place where you saved your maps in BMP format for the
slideshow.

3. Select a map you want to add, and click Open.

4. The map name now appears in the list of slides in Mapmakers Slideshow.
In addition, a small version of the map is displayed in the preview box.

5. To add another slide, click Add Slide again, and repeat the process until

you have added all the slides you want to your show.

Note: You can rearrange the order of your slides after you have added them
to the show. See Rearrange Slides on the next page for more information.




Delete a Slide

To delete a slide from your slideshow:

1. Click the name of the slide to select it. A small version of the map
is displayed in the preview box.

2. Click Delete Slide. The slide is removed from the slideshow.

Note: When you delete a slide from the slideshow, it will still be present in the
slideshow folder.

Hide a Slide

You can “hide” a slide in a slideshow you've created so that it does not display
during your presentation, but is still saved as part of the show.

To hide a slide, click the square slide icon next to the slide’s name. The square
becomes grayed out, indicating that the slide is hidden. If you run your
slideshow, this slide will not display.

To put the slide back into the presentation, click the slide icon again. The
square becomes black, indicating that the slide is visible.

Rearrange Slides

To rearrange the slides in your show, click the name of a slide you want to
move to select it, and then simply drag and drop the slide into its new position.

Add Sound to Your Slideshow

You can easily add music, narration, or other sounds to your slideshow.
Mapmakers Slideshow even helps you record your own sounds to add. With
this feature, it’s easy to create a narration to go along with your show.

To record a sound:

1. Make sure your computer has a microphone and is capable of recording
and playing sounds.

2. Choose Record Sound from the File menu.

3. When you are ready to begin recording, click the Record button and
begin recording.

4. When you are finished recording, click Stop. You can then play back your
recording by clicking Play.

5. Ifyou are satisfied with the recording, click Save. Type a name and
choose a place to save your sound.

6. If you are not satisfied with the recording, click the Record button and
try again.

You can attach sounds to each slide in your show. You can use sounds
that you record yourself, or some of the sample sounds provided on the
Mapmakers Toolkit CD-ROM. Sounds must be in AIFF format (for
Macintosh) or WAV format (for Windows).
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tip
If you have written a
narration to go along
with your slideshow,
you should create a
separate recording to go

with each slide. A continuous
recording will not work.
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tip
You can add sounds to
your show, and then choose
not to play them. Simply turn
off the Play Sound option.
The sounds are still there,

but you won't hear them
when you run the slideshow.
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To add a sound:

1. After adding slides to your show, click the name of the slide to which you
want to attach sound.

2. Click Add Sound. A dialog box appears.

3. Navigate to the place where you've saved your sounds in AIFF or WAV
format. If you want to use one of the sample sounds included with
Mapmakers Toolkit, navigate to the Sample Sounds folder on the CD.

4. Click the name of the sound you want to add and click Open.

5. In the list of slides, a sound symbol appears next to the slide to which
you attached the sound. When you run your slideshow, the sound will play.

To remove a sound from the slideshow, click the name of the slide you want
to remove sound from and click Delete Sound.

You can also “hide” individual sounds so that they do not play during the
slideshow. To do this, click the sound icon next to the slide’s name. The icon
becomes gray, indicating that the sound is hidden. If you run the slideshow,
that sound will not play.

To turn the sound back on, click the icon again. The icon becomes black
indicating that the sound will play.

Create a Title Slide

You can use Mapmaker’s Toolkit to create a colorful title slide for your slide-
show. Here’s how:

1. Open Mapmakers Toolkit. In Find mode, select Use Blank Map from the
File menu. The program presents a white map area in Draw mode.

2. Use the Text tool to create a title. If you wish, use the Standard Fill tool
to give the slide a background color other than white.

3. Choose Save from the File menu, and save the file in case you need to
edit it later.

4. Select Export As BMP from the File menu.

5. Give the file a name (other than the one you used in step 3) and click Save.

Then, in Mapmaker’ Slideshow, do the following:

1. Click Add Slide.

2. Locate the title slide you saved as a BMP and select it.

3. Click Open. The title slide appears in the list of slides.

4. If needed, drag slide to the desired position in the slide list.
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Save Your Slideshow

You can save a slideshow to play or add to later. To save your slideshow:

1. Choose Save from the File menu. A dialog box appears.

2. Type a name for your slideshow and click Save.

In order for the slideshow to run, it must be saved in the same folder as all
the slides and sounds used in the show. When you add a slide to the show,
Mapmakers Toolkit automatically creates a copy of the slide and places it in
the same folder as the slideshow. This feature makes it easy for you to gather
slides and sounds stored anywhere on your computer and save them all in one
place. If you remove any of the slides from this folder, the slideshow will not
be able to find them and they will be removed from the show.

Open a Saved Slideshow

To open a previously saved slideshow, click open on the Mapmaker’s Slideshow
main menu, or choose Open from the File menu. A dialog box appears.
Navigate to the place where you saved your slideshow, select it, and click Open.

Run a Slideshow

To run a slideshow:

1. Click Run Slideshow, or choose Run from the File menu.

2. The slideshow will run according to the options you selected. If you did
not choose Auto Advance, click the mouse button to advance each slide.

3. When the slideshow is finished, the program returns to the main
Mapmakers Slideshow screen.

Stop a Slideshow

You can stop a slideshow at any time by pressing the Escape (Esc) key or “Q”
on your computer’s keyboard. This returns you to the Mapmakers Slideshow
main screen.
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You can make your slideshow
images fill the computer screen

by changing the monitor’s resolution.

A resolution of 640 x 480 pixels will
create the largest possible image.
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Slideshow Options

There are some options that allow you to easily change the look and feel of
your slideshow. An option is turned on when it’s button is depressed. To turn
off an option, click the button to deselect it.
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Slideshow options

Background Color

You can change the background color that appears around the slides during
a slideshow. The default background color is white.

1. Click Background Color or choose Background Color from the Options
menu. The Select Color dialog box appears.

2. Click a color on the color palette to choose a background color, then

click OK.

3. The color you chose appears in the display square next to the Background
Color button. When you run the slideshow, the space around each slide
will fill with that color.

Loop

The Loop option lets you cycle through a group of slides again and again
without returning to the main Mapmaker’s Slideshow screen.

To loop your slides, click Loop or choose Loop from the Options menu. The
button becomes depressed and the option is turned on. To turn it off, click
Loop again. The button is deselected and the option is turned off.

When you are running a slideshow on a loop and you want to return to the
Mapmakers Toolkir main screen, press the Escape (Esc) key on your
computer’s keyboard. This interrupts the slideshow and returns you to the
Mapmakers Toolkir main screen.




Fade
The Fade option lets you fade slides in and out of each frame.

To make your slides fade in and out, click Fade or choose Fade from the
Options menu. The button becomes depressed and the option is turned on.
To turn it off, click Fade again. The button is deselected and the option is
turned off.

Note: If the Fade option is turned on, all slides will fade in and out.

Show Cursor

You can choose not to display the cursor over your slides. (The default setting
is to show the cursor.)

To turn the cursor off, click Show Cursor or choose Show Cursor from the
Options menu. The button is deselected and the option is turned off.

To make the cursor visible, click Show Cursor again. The button becomes
depressed and the option is turned on.

Play Sounds

You can choose not to play sounds you have added to your slideshow.
(The default setting is to play sounds.)

To turn sounds off, click Play Sounds or choose Play Sounds from the
Options menu. The button is deselected and the option is turned off. To play
sounds, click Play Sounds again. The button becomes depressed and the
option is turned on.

You can also “hide” individual sounds, so that they do not play during the
slideshow. To do this, click the sound icon next to the slide’s name. The icon
becomes gray, indicating that the sound is hidden. If you run the slideshow,
that sound will not play.

To turn the sound back on, click the icon again. The icon becomes black
indicating that the sound will play.

Auto Advance

You can choose to have your slideshow run automatically.

1. Click Auto Advance or choose Auto Advance from the Options menu.
The button becomes depressed and the option is turned on.

2. You can now select the amount of time you want each slide to display.
Type a number into the text box. (The default is 5 seconds.)

3. When you run your slideshow, the computer will automatically advance
the slides for you.

4. To turn off Auto Advance, click Auto Advance again. The button is
deselected and the option is turned off.

Note: If you have a sound attached to a slide, the slide will not advance until the
sound finishes playing.

FEATURES & FUNCTIONS

You may find the cursor

helpful to use as a pointer
during slideshows.
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Shortcuts & Tips

Keyboard Shortcuts

To activate a keyboard shortcut, first hold down the modifier key (Command
for Macintosh, and Control or Alt for Windows), then press the key identi-
fied in the charts below. Note that the Command key on Macintosh is
denoted by the symbol 3.

Menu [tem Macintosh | Windows What It Does
Find & Draw Modes
File New #FN Ctrl + N Opens a new World map in Find mode.
Open #+0 Cul + O Opens a previously saved Mapmaker’s

Toolkit-type map in Draw mode.

Print F+P Cul + P Opens the Print dialog box where you
can print a map according to the settings
in Page Setup. (The default is to print
the map on one page with no legend.)

Quit/Exit #F+Q Ale + F4 Quits Mapmaker’s Toolkit.
Help |Help Contents 36+ 2 F1 Opens the online Help.
About Found under | Found under
Mapmakers the Apple | the Help menu
Toolkit menu
Find Mode Only
Find Back Left Arrow Left Arrow Displays the previous map.
Key Key
Forward Right Arrow | Right Arrow Displays the next map.
Key Key (Available only after Back is used.)
Book- Add 3.8 Cul +B Adds a map to your bookmarks folder.
marks Bookmark
Draw Mode Only
File Save 38+ s Cerl + S Saves a map as a Mapmaker’s
Toolkit-type file.
Edit Undo #Hiz Cul +Z Undoes your last action.
Clone ¥} C Cul + C Creates a duplicate of the selected item.
Delete 3#.D Cul + D Deletes the selected item.
Select All ¥+ A Cul + A Selects all items on the map. Click the
Marquee tool and choose Select All to
select all lines and shapes. Click the
Selection tool and choose Select All
to select all stamps and text.
Build Legend o+ L Cul+L Opens the Legend dialog box.

Mapmaker’s Toolkit Shortcut Chart
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Menu ltem Macintosh | Windows What It Does
File New F+N Cul + N Opens a new slideshow.
Open o) Cul + O Opens a previously saved slideshow
Save F#+s Cul + S Saves a slideshow.
Run #+R Cel + R Runs a slideshow.
Quit/Exit #FQ Alt + 4 Quits Mapmaker’s Slideshow.
Help | Help Contents ¥+ F1 Opens the online Help.
About Found under | Found under
Mapmaker’s the Apple | the Help menu
Toolkit menu
When running a slideshow:
Next Slide [ space or return | space or return Press once to advance the slide.
Stop Show Escape Escape Press to stop the slideshow
(Esc) or Q (Esc) or Q and return to the main
Mapmaker's Slideshow screen.

Mapmaker’s Slideshow Shortcut Chart

Border Fill Tips

The Border Fill tool adds color to political areas on maps. The terms “border”
and “boundary” are used here interchangeably. They refer to any line separat-
ing two or more political areas.

Note: Border Fill and Standard Fill act independently of each other. Standard
Fill is used to fill in shapes you have drawn on the map. Standard Fill colors will
always appear on top of Border Fill colors.

Quickly delete all border fill you've added to the map:

1. Turn off all boundary layers in the Layers dialog box.
2. Click the Border Fill tool on the toolbar and then select the Border
Fill Eraser. Border Fill Eraser

3. Click on any land area. All border fill color will be removed.

Fill overlapping boundaries:

Many maps, both current and historical, have overlapping boundaries. For
example, the current map of Africa contains three boundary layers: continent,
regional, and international.

Generally, the Border Fill tool fills the smallest visible political area on a map
so you will need to turn off some boundary layers in the Layers dialog box in
order to fill others. For example, to fill the regions on the map of Africa, you
will first have to turn off the international boundaries layer and turn on the
regional boundaries layer.
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Some historical maps may require more experimentation to achieve the look
you want. Where there are overlapping boundaries, first try turning on and
filling each boundary layer individually to see the results. This will help give
you an idea of how to create the look you want when all the boundary layers
are turned on.

Change the Subject Highlight color:
The default color for the Subject Highlight is tan.

1. In the Layers dialog box, turn all boundary layers off and turn the Subject

Highlight layer on.
% I 2. Click the Border Fill tool on the toolbar.
Border Fill tool 3. Select a color on the color palette.

4. Click anywhere on the Subject Highlight.

Change the color of all land areas on the map:

The default color for land area is light yellow.

1. In the Layers dialog box, turn off all boundary layers and the Subject
Highlight layer.

2. Click the Border Fill tool on the toolbar.

3. Select a color on the color palette.

4. Click anywhere on the land area.

Now you can turn boundaries on again and fill them with other colors if

you wish.

Change the color of bodies of water:

1. Click the Border Fill tool on the toolbar.

2. Select a color on the color palette.

3. Click on any body of water, except rivers. All water bodies, except rivers,
will fill with the color you have selected.

Make an outline map:

1. In the Layers dialog box, turn off all boundary layers and the Subject
Highlight layer.

2. Click the Border Fill tool on the toolbar.
3. Select white on the color palette.
'\%’:. 4. Click anywhere on the land area to fill with white.
? 5. Click any body of water to fill with white.
Border Fill tool If you wish, you can change the shoreline color to black to create a black and

The tip of the paint is

N white outline map.
the insertion point.

1. Click the Border Fill tool on the toolbar.

2. Select black on the color palette.
“ 3. Click the Zoom In button, or select Zoom In from the View menu.
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4. Locate an area of blue shoreline. (It’s easier to change the color using a
thick area of shoreline.)

5. Click the shoreline with the tip of the flowing paint on Border Fill bucket.

If you click land or water by mistake, click the Undo button (or select Undo
from the Edit menu) and try again.

Using Maps on the Internet

Visit the Tom Snyder Productions Web site for the latest tips on how to use
your maps on the Internet. Go to www.TeachTSP.com.

The Art of Cartography

Mapmaking, or cartography, is an ancient art. Many maps, both old and new,
are as beautiful to view as they are practical to use. And the measure of any
good map is its readability. Two key elements of maps that make them
readable and understandable are color and text. Here are some basic guide-
lines for making your maps functional works of art.

Type

Generally, use only one or two typefaces on your map. Use a serif type (such
as Times or Palatino) for place names, and a sans-serif type (such as Arial or
Helvetica) for bodies of water and islands. Use only three styles of text: plain,
bold, and 7zalic. By combining two typefaces and three type styles, you have
six options that will make your maps clear and uncluttered.

Color

As with type, the rule for using color on a map is: less is more. Look carefully
at a map in a book or on a wall. You'll notice that most maps contain only
five or six colors. Too many colors clutter the map and make it difficult to read.

Mapmakers Toolkit provides a palette of 33 colors. These colors were carefully
chosen to make your map attractive and readable. The palette contains the
primary colors (red, blue, and yellow) and secondary colors (violet, green,
and orange), plus black and white. There are also varying shades (light,
medium, dark, and bright) of yellow, orange, red, purple, blue, green, brown,
and gray.

For lines, use dark colors (black, red, green, blue) because they stand out
against the map background.

For filling areas with the Border Fill tool you have two options: use contrast-
ing or complementary colors. For contrasting colors, use these combinations
together: red and green, or purple and orange, or yellow and blue. For
complementary colors, use four or five shades of the same color group:
yellows with oranges, pinks with reds, blues, purples, greens, or grays.
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Technical Support
& Troubleshooting

Technical Support

If, after reading through the Features & Functions section you are still having
trouble, please call our Technical Support team at 1-800-342-0236.

When you call, please have the following information available:

* Software title and version number. These can be found on the CD-
ROM and in the About Mapmaker’s Slideshow dialog box (under the
Apple menu if you're using Macintosh; under the Help menu if
you're using Windows)

* Your computer platform (e.g., Windows 95 or 98; Macintosh; Power
Macintosh)

* Your computer model (e.g., Power Macintosh 6100; Compaq Prolinea)

* Your computer’s memory (e.g., 24 megabytes of RAM)

* Your computer’s processor and speed (e.g., Pentium processor running

at 200 MHz)

If possible, please have the software running on a computer close to the
telephone when you call.

Our technical support staff is available Monday through Friday, 9 a.m.
to 6 p.m. EST. You can also e-mail us at Tech@TeachTSP.com.

Troubleshooting

I get a "Please locate the map data." message.

For the CD-ROM version, insert the CD, wait a moment, and click Retry.
For the Network version, this message will appear when your connection

to the Data folder has been interrupted, or when the Data folder has been
moved. First, log onto the network server that contains the Data folder then
click Retry. If that does not work, click Locate, navigate to the Data folder,
and click Select.

I can’t find the Theme maps.

Please see the instructions for locating the theme maps folder under Prefer-
ences on page 60.

Some of the draw tools are “grayed out” and unavailable.

If you turn off “My Features” layers such as Border Fill or Stamps, these items
will become dimmed on the Draw toolbar. You won't be able to add those
features to the map unless you turn the layers on again in the Layers dialog box.
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When I paste a picture onto a map, the colors change.

Mapmakers Toolkit uses 256 specific colors, called a palette, to display images.
If your picture contains a color not in the palette, the program will try to
match it to the closest available color. In addition, pure white is treated as
transparent. That way, if you have an item with white border, the white
border will not appear. If you want to keep that border, use the drawing tools
to add white to the image.

I see a blank screen when I try to find a map.

After you started the program, you either removed the Mapmakers Toolkit
CD from the CD-ROM drive, or your computer was disconnected from the
network where the Mapmaker’s Toolkit data is stored. To resolve the problem,
put the CD-ROM back in the drive, or reconnect to the network.

My slideshow is not showing all/any of the slides I added to it.

It’s important that the slideshow file be in the same folder as all the slides and
sounds it uses. When you create a slideshow, the program automatically saves
all the files in one folder. But if you move the slideshow out of that folder
later, it will no longer be able to find the files it needs. To solve the problem,
put the slideshow file back into the folder with all the slides and sounds.

The scale on my map changed colors.

Sometimes, when you use the Border Fill tool, the scale on your map will get
filled in with color. If you use the Border Fill Eraser to remove color from the
map, the scale remains filled in with color. To remove it, click on the scale

with the Border Fill Eraser.

I get an “Insufficient memory!” message when I try to scale an item.
The print preview screen is blank and I get an “Insufficient memory!” message.

1. Quit Mapmakers Toolkit.

2. Locate the Mapmaker’s Toolkit program icon and click it once to select it.

3. From the File menu, choose Get Info. The Mapmaker’s Toolkit Info
dialog box appears.

4. In the box next to Preferred Size, increase the value. (The default is
12000 K.) If the Preferred Size box is grayed out, check to see that you
have quit Mapmakers Toolkit. First try to increase the value to 14000. If
the problem persists, increase it to 16000 and so on.
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Classroom Activities

Mapmakers Toolkit is a powerful, open-ended tool that helps you easily
incorporate maps into many aspects of your curriculum. Most of the activities
listed below use the layering and drawing features of Mapmakers Toolkit to
enhance your students’ knowledge of history, geography, and science.

Activities that have Internet-related resources are marked with a special
symbol. Visit our Web site at www.TeachTSP.com and go to the Online
Activities section to find the most up-to-date classroom activities, and links
to useful geography sites. Also, visit our site to learn how to get additional
Theme Maps that meet your curriculum needs.

If you have a fun map activity to share, write us at Tom Snyder Productions,
80 Coolidge Hill Road, Watertown, MA 02472, or e-mail us at
Ask@TeachTSP.com.

Geography

Five Themes:

1. Location: Position on Earth’s Surface

Describe the location of a place by what is West, East, North, and South
(WENS) of it. For example, you could write, “The secret place is west of
Missouri, east of Colorado, north of Oklahoma, and south of Nebraska.”
(The secret place is Kansas.) Have students write “WENS and Where” clues

for each other. Awards can be given for difficulty and cleverness.

2. Place: Physical and Human Characteristics

Human Characteristics

Use the built-in theme maps to compare population density of various places
around the globe. What geographic characteristics do densely (or sparsely)
populated places share?

Physical Characteristics

Use the built-in theme maps to compare temperature, precipitation, and
vegetation of various places around the globe. What places on Earth share the
same characteristics as your hometown?

3. Relationships within Places: Humans and Environments

Use the Population Density theme maps to offer explanations about why
people live where they do. What characteristics do population centers share?




Classroom Activities

4. Movement: People Interacting on Earth

Using the world map and the Border Fill tool, rank the top five countries
from which immigrants arrived in the United States in three periods (1850,
1910, and today). How have immigration patterns changed over time?

5. Regions: How They Form and Change

Redraw regional boundaries of a continent based on various criteria such as
language, landform type, economics, ethnic groups, or religion.

Other Geography Activities

Travel Brochure

Incorporate Mapmakers Toolkir maps in a travel brochure highlighting a
travel destination. Show transportation hubs (airports, bus terminals), points
of interest, and so on.

Make an Atlas -
Create a student-published atlas. Maps from the program can be added easily %
=

to word processing and page layout documents. Data on countries and U.S.
states can be found on the Internet. Here are a few sites to check out:

CIA World Factbook for basic information about the countries of the world.
(www.odci.gov/cia/publications/factbook)

United Nations Food and Agriculture Organization Statistics for informa-
tion on major products around the world. (www.apps.fao.org)

Census Bureau Data Maps, the “official source” for information about the
50 U.S. states. (www.census.gov/datamap/www/index.html)

Map Puzzle

Print out a blank outline map of the U.S. with the state labels turned off,

and cut out each state. Divide students into five groups and give each group
all the states in one region: Midwest, West, Southwest, Southeast, and North-
east. (See the U.S. regional maps to determine which states are in which
regions.) Have the students assemble the states in their region as they should
appear on the map. Then the groups can put their completed region maps
together to form a map of the U.S. When they’re finished, they can trade
regions with another group, and go through the game again.

Made in the USA

Use the products and industries stamps to create a map showing products
made in the United States, or any other country, region, or continent.

Ask students to make observations about why certain products are made in
different regions.
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Science

Weather

Track hurricanes, storms, El Nifio, and other weather events using weather
— Web sites such as the National Weather Service. (www.nws.noaa.gov)

Climate

Use the program’s built-in climate theme maps (January Temperature, July
Temperature, Precipitation, and Vegetation) to compare the climates of
various places. Use the theme maps as bases on which you can add other data
such as population, transportation routes, etc.

Weather Disasters

Students can create a map of recent weather disasters, and their associated
cost in property damage and lives lost, with data from the National Climatic
Data Center. (www.ncdc.noaa.gov/ol/reports/billionz.html)

Habitats/Biomes

Use the Vegetation theme map to show where rainforests and other habitats
are located. Add population data to see if students can identify any connec-
tion between habitats and human population.

Pollution

Track oil spills, acid rain (identify sources and affected areas), ozone damage
(track the size and location of the hole in the ozone layer over time) in your
area, and around the world.

Earthquakes

Chart major earthquakes using information from the U.S. Geological Survey

AW

== Web site. Based on the locations of the major earthquakes, can students
predict where fault lines might exist? They can draw on their map where they
think faults might be, then verify their answers with a map of Earth’s tectonic
plates. (quake.wr.usgs.gov)

Rainforests

Use the Vegetation theme maps to identify the locations of the world’s
rainforests and track areas threatened by deforestation and other factors that
harm rainforest ecosystems.
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History

Map Explorers’ Routes

As students study European explorers to the New World, they can plot their
routes on a map of the North Atlantic ocean. Print the map on multiple
pages for classroom display. Use the Tom Snyder Productions software pro-
gram TimeLiner to create a time line of exploration depicted on the map. You
can also copy the map you create from Mapmaker’s Toolkit and then paste it
into your ZimeLiner time line. Or, export the map as a PICT or BMP file,
and resize it in a drawing program before pasting.

Model Making

Print out a poster-size map of the United States, 1650. Tape it to the floor

or a table and use the Tom Snyder Productions software program Community
Construction Kit to create models of early communities, such as Jamestown,
Plymouth, St. Augustine, or New Amsterdam to place on the map.

U.S. Historical Census Data

Students can create a slideshow of population changes in the United States
using historical census bureau data. Have them look at which areas have =3
grown the most rapidly in the last 30 years, in the 30 years before that,

and so on. What changes do they see? (fisher.lib.virginia.edu/census/)

Trade Routes

Map trade routes through history, including the Silk Road in Asia, and the
Triangular Trade across the Atlantic.

War Battles

Depict the locations of famous battles, including the Punic Wars, the
American Civil War, and the World Wars. Show troop movements and
have students explain the military strategies behind the maps.

Immigration Patterns

Choose an immigrant group and map where it has settled, either across the
country, or in a state or province. Choose colors and/or symbols to identify
population size. When the map is complete, identify the factors that have
influenced where the group settled.

Election Results

Create a theme map of U.S. presidential elections showing which states voted
Republican or Democrat (or for other parties). Compare the maps and look
for patterns. Do some regions or states always vote for the same party?

Are some regions generally liberal and others conservative?
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Other Activities

Sports

Use the sports stamps to show the locations of professional sports teams and
locations of the Olympic Games.

Mapping Literature

Students can make a “literary map” that labels the homes of some of their
favorite characters. Then they can select passages from those books that
describe the geography/physical environment and copy these descriptions
onto the map.

Local Industry

Map the industries in your area, then find out where else in the world those
goods and products come from. Do the areas share any geographic similari-
ties? What are the differences?

Place Names & Language

Choose a continent map and label each country with its name in the local
language (e.g., Germany becomes Deutschland; Italy becomes Italia). Alterna-
tively, have students label each country on a map in the language they are
studying (e.g., if you are studying French, the United States becomes les Etats-
Unis).




Social Studies
Curriculum Guide

Tom Snyder Productions has organized its social studies materials around
three critical themes: time, place, and citizenship. These themes form the
backbone of a traditional social studies curriculum — chronological history,
geography, and government — and, perhaps more importantly, they are
especially relevant to today’s changing world.

Time

We exist in a flow of time; the present is a consequence of the past and leads
to the future. Learning about what has happened before and understanding
the potential relationships among events can give us great power and insight
over the world that surrounds us now.

Place

Of course, we also all live in a place. And the political, geological, and eco-
logical elements of that place have an enormous influence over our lives.

Citizenship

Finally, we all live as citizens in local and global communities. Our continued
existence depends upon our ability to communicate, negotiate, and resolve
the differences and issues which threaten those communities.
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Time

Grade Level
K-12

Topics Covered

chronology;
cause & effect;
time lines

Program

TimeLiner

Description

This powerful tool allows you and your
students to create, edit, illustrate, and merge
time lines of all types.

Grade Level
4-9

5-10

5-10

5-10

MAPMAKER'S
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Topics Covered
historical geography;
physical and political
geography; maps and

map skills

colonial history

immigration (all periods
in U.S. history)

revolutionary wars

the Cold War;
history of U.S.
foreign policy

balance of power;
separation of power;
ratification;
great compromise

westward expansion;
growth of cities

westward expansion;
causes of the Civil War;
U.S. historical geography

Program
Mapmakers Toolkir

Decisions, Decisions:

Colonization

Decisions, Decisions:

Immigration

Decisions, Decisions:

Revolutionary Wars

Decisions, Decisions:

The Cold War

Decisions, Decisions:

The Constitution

Decisions, Decisions:

Town Government

American History Inspirer:

The Civil War

Description

This mapping tool allows you to locate over
325 present-day country, region, and state
maps, as well as 125 historical maps, includ-
ing over 30 maps from U.S. history. You can
customize a map, adding color, text, and
stamps, and then print in multiple sizes or
save for publishing on the Internet.

The situation is the colonization of outer
space, but the historical examples illustrate
early U.S. history.

Students, role-playing the president of the
U.S., use history to guide them through a
refugee crisis.

Students take on a role similar to that of a
colonial governor on the eve of a revolution.

Superpowers face off as students are guided by
the past to determine how to relate to their
world neighbors.

After gaining its independence from Tyria, the
confederation of Merrimac is in trouble. Your
students, role-playing a delegate to Merrimac’s
constitutional convention, must wrestle with
the same issues that faced the founding fathers
of America in 1787.

As mayor of a potential boom town, students
grapple with issues of urban growth in U.S.
history.

Cooperative teams of students go on a
scavenger hunt through American history
around the time of the Civil War.




Time

Social Studies Curriculum guide

World History

Grade Level
4-9

5-10

5-10

5-10

Topics Covered
historical geography;
physical and political
geography; maps and

map skills

Age of Exploration

ancient civilizations

African history;
European colonialism;
modern nationalism

Middle Ages;
feudalism;

the Crusades

the Cold War;
history of U.S.

Program
Mapmakers Toolkir

Geography Search

Decisions, Decisions:

Ancient Empires

Decisions, Decisions:

Building a Nation

Decisions, Decisions:

Feudalism

Decisions, Decisions:

The Cold War

Description

This mapping tool allows you to locate over
325 present-day country, region, and state
maps, as well as 125 historical maps of Asia,
Europe, Africa, and the Americas from 3000
B.C. to the present. You can customize a
map, adding color, text, and stamps, and
then print in multiple sizes or save for
publishing on the Internet.

Cooperative teams of students use the
stars and the wind to navigate their way

to the New World.

This role-playing simulation exposes students
to many ancient civilizations, including

Egypt, Greece, and Mesopotamia.

As the leader of a newly independent nation,
students must form a government and create
an economy to unite their people.

In the role of a feudal lord, students
must respond to their feudal obligations
and responsibilities.

Superpowers face off as students are guided
by the past to determine how to relate to
their world neighbors.
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Place

U.S. Geography

Grade Level
4-9

Topics Covered

physical and political

geography; historical

geography; maps and
map skills

U.S. locational
geography; resource
distribution

westward expansion; causes

of the Civil War; U.S.
historical geography

Program
Mapmaker’s Toolkit

National Inspirer

American History Inspirer:

The Civil War

Description

This mapping tool allows you to locate over
450 maps including 191 countries, 5 U.S.
regions, 50 U.S. states, and 125 historical
maps (30 from U.S. history). You can
customize a map, adding color, text, and
stamps, and then print in multiple sizes or
save for publishing on the Internet.

Cooperative teams of students go on
a scavenger hunt for resources across
the United States.

Cooperative teams of students go on a
scavenger hunt through American history
around the time of the Civil War.

World Geography

Grade Level
4-9

5-12

Topics Covered

physical and political

geography; historical

geography; maps and
map skills

locations of over 180
nations; national
characteristics

political & physical
geography of Africa,
Asia, Europe

political & topographical

geography; latitude
and longitude;
mapmaking

Program
Mapmaker’s Toolkit

International Inspirer

Africa Inspirer
Asia Inspirer
Europe Inspirer

Mapping the World
by Heart

Description

This mapping tool allows you to locate over
325 present-day maps, including 191
countries, 33 dependencies, and 20 world
regions, as well as 125 historical maps. You
can customize a map, adding color, text, and
stamps, and then print multiple sizes or save
for publishing on the Internet.

Cooperative teams of students go on a
scavenger hunt around the world for physical
and cultural characteristics.

In these three software programs cooperative
teams of students go on a scavenger hunt for
resources across Africa, Asia, or Europe.

With this print-based curriculum, your
students will know political and physical
geography by heart, and become expert
mapmakers too.

World Cultures

Grade Level
4-12
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Topics Covered

social, economic,
and cultural traits
of world nations

political & physical
geography of Africa,
Asia, or Europe

world cultures; cultural
diversity; science,
technology, and society;
environmental issues

Program

International Inspirer

Africa Inspirer
Asia Inspirer
Europe Inspirer

Cultural Debates

Description

With this cooperative search activity, students
uncover national and regional characteristics

of the world.

In these three software programs, cooperative
teams of students go on a scavenger hunt for
resources across Africa, Asia, or Europe.

Students examine a rainforest community to
learn about cultures, modernization, and the
environment. Features original video from
the Indonesian rainforest.
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People & Their Environment

Grade Level
1-5 geography; direction;
scale; distance; ordinal

and cardinal directions

Topics Covered

2-6 community; local
geography; architecture;
direction and spatial
relationships

2-6 local environment;
environmental
responsibility

environmental issues; the
economy;
government

5-12

the science of weather;
how global climate

changes affect people’s

livelihoods and safety

Program

Neighborhood
MapMachine

Community
Construction Kit

Choices, Choices:
Kids & the Environment

Decisions, Decisions:
The Environment

Ocean Expeditions:
El Niio

Description

As students create maps of their own neigh-
borhoods, they learn about direction, scale,
distance, and other essential geography
concepts. Students can also create geography
mysteries and scavenger hunts.

Students design buildings on the computer,
print them, and then cut and fold them to
create 3-D scale models of historical and
contemporary communities.

The school playground is a mess; students
must find the cause and figure out how to
clean it up.

A polluted pond and a big employer force
students, as mayor of the town, to consider
politics, economics, and the environment
while making tough decisions.

Working in teams of four, students role-play
scientists who collect and interpret data in
order to assess the El Nifo effect.

Geography Skills

Grade Level

1-5 geography; direction;
scale; distance; ordinal
and cardinal directions

Topics Covered

2-6 community; local
geography; architecture;
direction and spatial
relationships

4-9 physical and political
geography; maps and
map skills; historical

geography

latitude and longitude

5-12 political & topographical
geography; latitude and

longitude; mapmaking

Program

Neighborhood
MapMachine

Community
Construction Kit

Mapmaker’s Toolkit

Geography Search

Mapping the World
by Heart

Description

As students create maps of their own neighbor-
hoods, they learn about direction, scale,
distance, and other essential geography
concepts. Students can also create geography
mysteries and scavenger hunts.

Students design buildings on the computer,
print them, and then cut and fold them to
create 3-D scale models of historical and
contemporary commuanities.

This mapping tool allows you to locate over
450 present-day and historical maps. Each
map contains many built-in layers including
rivers, shaded relief, cities, and more that you
can turn on or off to suit your needs. You can
customize a map, adding color, text, and
stamps, and then print in multiple sizes or save
for publishing on the Internet.

Cooperative teams of students use the tools
of early sailors to learn about latitude and
longitude.

With this print-based curriculum, your
students will know political and physical
geography by heart, and become expert
mapmakers too.

MAPMAKRER'S
TOOLKIT




Social Studies Curriculum guide

Citizenship

Government & Economics

Grade Level Topics Covered Program Description
5-10 African history; Decisions, Decisions: As the leader of a newly independent nation,
European colonialism; Building a Nation students must form a government and create
modern nationalism an economy to unite their people.
5-10 presidential elections; Decisions, Decisions: As a candidate for president, students learn
politics; current events On the Campaign Trail ~ about election politics while grappling with
the issues.

5-10 civic responsibility; Decisions, Decisions: As mayor of a potential boom town, students

local government Town Government must work with competing groups to build

consensus over a controversial issue.

Rights & Responsibilities

Grade Level Topics Covered Program Description
5-10 prejudice; local Decisions, Decisions: Students take on the role of a town mayor
government; Prejudice who must respond to an offensive storefront.
freedom of speech
5-10 freedom of speech; Decisions, Decisions: As an advertising executive, students deal
media violence; Violence in the Media with media violence and learn about the
citizen action media industry.
Ethics & Behavior
Grade Level Topics Covered Program Description
K-4 personal responsibility; Choices, Choices: Critical thinking model helps address issues
honesty Taking Responsibility of responsibility and honesty.
K—4 peer pressure; prejudice Choices, Choices: Students learn to recognize the similarities
On the Playground and differences among all individuals.
4-10 drugs; peer pressure Decisions, Decisions: You catch your friend in the middle of
Substance Abuse a drug deal; what do you do?
5-10 personal responsibility; Decisions, Decisions: Peer pressure challenges students playing the
honesty Lying, Cheating, Stealing  role of a new kid in school.

MAPMAKER'S
TOOLKIT
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Activities 78-82

Back 7, 39
Blank Map 33, 59, 68
Bookmarks 10, 39-40
Add 10, 39
Folders 40
Organize 40
Select 10, 39
Border Fill 17-19, 49-50, 73-75
Delete All 73
Erase 18, 50
Tips 73-75
Border Fill Tool 13, 44
Build Legend 22-23, 55-57

Clipboard 58

Clone (Duplicate) 48, 54
Lines 48
Shapes 48
Stamps 54
Text 54

Color
Change Land Areas 74
Change Subject Highlight 74
Change Water 74
Tips 75

See also Border Fill or Standard Fill

Copy See Clone
Copy Map 58, 63
Copyright 3
Cross Platform 34

Delete
Lines 48—49
Shapes 48-49
Stamps 54
Text 54
See also Undo
Draw
Line 45
Shape 46
Draw Mode 12, 41

Draw Toolbar 13, 44
Duplicate See Clone

Ellipse 46
Ellipse Tool 13, 44
Eraser 20, 49
Eraser Tool 13, 44
Error Messages 7677
Export Maps 26-27, 64-65
File Formats 64
for Slideshow 27, 64
for Internet 64

File Formats 64

Fill See Border Fill or Standard Fill

Find Maps 6-10, 35-38
Current Maps 6-9, 35-36
Historical Maps 9, 37
Theme Maps 37

Find Mode 35

Forward 7, 39

Go to Draw Mode 40
Go to Find Mode 58

Help (online) 34

Import Map 38
Installation 5
Internet
Export Maps 64
Publish 33
Tips 75

Keyboard Shortcuts 72-73

Layers 11-13, 41-43
Access Map Layers 11, 41
Apply 41
Availability 43
My Features 13, 42-43
Order of 42
Physical Features 43
Political Features 43
Regions 8-9
Show All 41
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Show None 41 Blank Map 59, 68
Turn on/off 12, 41 Legend 55
Layers Button 41 Map 24, 38
Legend 22-23, 55-57 Mapmaker’s Slideshow 28, 65
Add Symbol 56 Mapmaker’s Toolkit 5
Build 22, 55 New Slideshow 65-66
Delete Entry 56 Sample Slideshow 65
Edit 55 Saved Slideshow 69
Edit Text 56 Outline Map 32, 74-75

Hide Basic Legend 56

Page Setup 25, 61
Move Entries 56 age setup

Paper Orientation 63

Open 55 Paste from Clipboard 54
Si"e 57 ‘ Pencil 45

Show Basic Legend 56 Pencil Tool 13, 44
Update 56

Preferences 59-60
Legend Reminder 57, 60
Theme map path name 59-60
Print 25-26, 61-63

Legend Button 22, 55
Legend Reminder 57, 60
Line Tool 13, 44

Lines 19-20, 45

Legend 62
Mapmaker’s Slideshow See Slideshow Multiple Pages 61
Maps One Page 61
Blank 33, 59, 68 Page Setup 25, 61
Current 6-9, 35-36 Paper Orientation 63
Historical 9, 37 Print Preview 61
Imported 38 Printer Setup 63

Number of 35

ick Ref 32-34
Outline 32, 74-75 Quick Reference

Saved 38 Rectangle 46
Theme 37 Rectangle Tool 13, 44
Marquee Tool 13, 44, 47 Regions 8-9
Ellipse 47 Run Slideshow 69
Lasso 47 Sample Slideshow 65
Rectangle 47 Save
Mo‘./e Legend 57
Llnes 47 Map 24’ 57—58
Shapes 47 Slideshow 69
Stamps 53 See also Export Maps
Texe 21, 53 Scale [tem 48
My Features 13 See Layers 41
Navigation Maps 7, 39 Select
New 40 Lines 47
Open Marquee Tool 13, 44

Selection Tool 13, 44

W Shapes 47

MAPMAKER'S
TOOLKIT




Stamps 53
Text 53
Select All
Lines and Shapes 47
Stamps 53
Text 53
Text and Stamps 53
Selection Tool 13, 44, 53
Shapes 20, 46
Ellipse 20, 46
Rectangle 46
Show Legend 22, 55
Slideshow 28-30, 65-71
Add Slide 29, 66
Auto Advance 71
Background Color 70
Create Title Slide 33, 68
Cursor 71
Delete Slide 67
Export Maps 26-27, 64-65
Fade 71
Hide Slide 67
Loop 70
New 65-66
Open 28, 69
Rearrange Slides 67
Record Sound 67
Run 69
Sample Slideshow 65
Save 69
Sound 30, 67-68, 71
Stop 69
WalkThrough Slideshow 28-30
Sound 59
Stamp Tool 13, 44
Stamps 15-17, 52-54
Add 52
Copy 54
Delete 54
Move 53
See All 52
Select 53
Sets 52
Standard Fill 46

INndex

Standard Fill Tool 13, 44

System Requirements 3

Text 21, 50-54
Add 50
Alignment 51
Color 52
Copy 54
Delete 54
Font 51
Format 51-52
Move 53
Rotation 51
Select 53
Size 51
Style 51
Text Tool 13, 44
Tools
Border Fill 13, 44
Border Fill Eraser 18, 50
Ellipse 13, 44
Eraser 13, 20, 44
Line 13, 44
Marquee 13, 44
Pencil 13, 44
Rectangle 13, 44
Selection 13, 44
Stamp 13, 44
Standard Fill 13, 44
Text 13, 44
Undo 13, 44
Troubleshooting 76-77

Undo 20, 48

Undo Tool 13, 44

Update Map Legend 55-56
Use Blank Map 33, 59, 68

WalkThrough Slideshow 28-30

Zoom In 59
Zoom Out 59

MAPMAKRER'S
TOOLKIT
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